When printing reports to PDF, you receive "Error in processing report. Error Details: The handle is invalid". In addition, when previewing or printing to paper, reports only print one line per page
Description
Cause

This issue is linked to a Windows 10 update (version 1903) released in early October 2019. The update potentially interferes with the Windows Print Spooler service and possibly your Windows account, which can affect printing in Sage 100 Contractor.

Resolution

IMPORTANT UPDATE: Microsoft has released a patch for the 1903 update for this issue. Please apply the latest Windows updates and reboot your machine. If the update does not resolve, please see the options below.

Option 1:

  1. Log into your company with administrative rights.
  2. In the 7-2-2 User List window, create a test user with Company Admin access.
  3. Log in with that test user and run a few reports to see if the same errors occur.
  4. If the test user does NOT receive the same errors:
    1. Stay logged in as the test user and return to the 7-2-2 User List window
    2. Click Copy User Defaults
    3. Select the test user on the left and the user that is getting the errors on the right
    4. Click OK and close the Copy User Defaults window
    5. Save the User List window
  5. Log back into Sage 100 Contractor again as the original user, and then test printing some reports

Option 2:

  1. Close Sage 100 Contractor
  2. Right-click on your Sage 100 Contractor desktop icon and select Properties
  3. Click on the Compatibility tab
  4. Check the box for Run this program as an administrator, click Apply, then OK
  5. Reopen Sage 100 Contractor using the desktop icon

Note: if you normally open Sage using an icon in the taskbar at the bottom or your screen, you must delete that icon, right-click on the desktop icon you modified, and then select Pin to taskbar

Important: When you open Sage using this method, you could potentially encounter the following issues:

  • Clicking the Outlook icon in report printing windows may cause the error "Unable to communicate with Outlook"
  • If you are saving a report generated in Sage and are browsing for a location to save the report to, you may not see your mapped network drives
  • You may not be able to attach files to records in Sage by dragging and dropping the files into the record

Option 3:

  1. Log off the computer and then log back into the computer as a Windows user who does not receive the error when printing in Sage 100 Contractor.
  2. Connect to Sage 100 Contractor and try printing again. If the error does not occur while logged in under this Windows user, contact your IT support for further assistance.

Option 4:

Uninstalling the Windows 1903 update and rebooting your machine has been found to resolve this issue. Microsoft has categorized this update as optional, so you may defer or deny the update in your Windows Update settings.

DocLink: How to copy user defaults

[BCB:154:Chat 100 Contractor US:ECB]
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