Auto-Complete does not display newly added customers, employees, items, or vendors
Description
Cause

New records are not indexed until the Build Search Index utility is run

Resolution

This is working as designed. Per the Help files for Sage 100: "To activate the advanced version of auto-complete search, in addition to selecting the Enable Auto-Complete check box in System Configuration, you must run the Build Search Index utility. Then as new records are created, you must rebuild the index so that they appear in the auto-complete search results."

Possible Workaround:

You can use Library Master, Main menu, Task Scheduler to automatically run the indexing utility on a regular basis. When creating the job in Task Scheduler, select Other in the Type field. Then on the Tasks tab, select Build Search Index from the Task list.

DocLink: How to enable, setup, and use the Auto-Complete feature for Customer number, Vendor number, and Item Number fields
DocLink: Auto-Complete no longer searches the beginning of text for Sage 100 (enhanced versus basic Auto-Complete)
Defect ID
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