Parallel Migration Fails When Copying SY_SagePEPTask
Description
Cause

Possible corruption of SY_SagePEPTask.m4t or SY_SagePep.m4t files in the source installation.

Resolution
[BCB:1:Backup warning:ECB]


Restore SY_SagePEP.M4T and SY_SagePEPTask.m4t from backup (or previous version).

Or download clean versions (see Attachments section) to the older (source) installation:

Once SY_SagePEP.m4t and SY_SagePEPTask.m4t files are restored from backup or extracted from the Attachments on this article they need to be copied to the old/Source and new/Target installations:

Source (old) install:

  1. In the source (older version) installation, browse to the ...\MAS90\MAS_SYSTEM folder
  2. Rename the following files:
    • SY_SagePEP.M4T
    • SY_SagePEPTask.M4T
  3. in the locataion where you restored the files or extracted the files, press Ctrl then select the SY_SagePEP.M4T and SY_SagePEPTask.m4t files that you restored or extracted from Knowledgebase article and right-click then select Copy
  4. In the old installation ...\MAS90\MAS_System\ folder, Right-click in any open area and select Paste

Target (new) install:

  1. In the new (target) installation, browse to the ...\MAS90\MAS_SYSTEM folder
  2. Rename the following files:
    • SY_SagePEP.M4T
    • SY_SagePEPTask.M4T
  3. in the locataion where you restored the files or extracted the files, press Ctrl then select the SY_SagePEP.M4T and SY_SagePEPTask.m4t files that you restored or extracted from Knowledgebase article and right-click then select Copy
  4. In the new installation ...\MAS90\MAS_System\ folder, Right-click in any open area and select Paste

After both old and new installs have the SY_SagePEP.m4t and SY_SagePEPTask.m4t existing files renamed and replaced with the replacement files:

  1. Re-run the migration again from the new installation (after replacing both old & new install sets of SY_SagePEP & SY_SagePEPTask files).

Attachment: 253_20230425111140_SY_SagePEP.zip


Additional information:

It is also possible to get a similar message when installing a product update referring to "error: #12 SY_sagepep.M4T" (or other Sage PEP file) due to file corruption which can also be resolved by extracting the \MAS90\MAS_SYSTEM\SY_SagePEP* files in this article's Attachments and replacing those files.


[BCB:155:Chat 100 US:ECB]


Defect ID
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