Error: "SQL is not enabled" when opening Sage 100 Premium 2021 or prior versions with TLS 1.0 and 1.1 disabled on SQL Server
Description

Cause
  • TLS 1.0 and 1.1 are disabled on SQL Server
Resolution
[BCB:1:Backup warning:ECB]


[BCB:5:Third-party support:ECB][BCB:5:Third-party support:ECB][BCB:5:Third-party support:ECB][BCB:5:Third-party support:ECB]

Possible Workaround

  1. Verify Micrososft SQL Native 11.4.7001 is installed on Server and workstation(s) (NOTE: Use Program and Features)
  2. Modify ....\MAS90\HOME\massql.settings in Notepad
  3. Change 'SQLOLEDB' to 'SQLNCLI11' under @Reporting section
  • Example: Provider=SQLNCLI11;Data Source={dsn};User ID={username};Password={password};

DocLink: Error: “The database login failed. Failed to open the connection. Details: [Database Vendor Code: 17]”

[BCB:155:Chat 100 US:ECB]

Steps to duplicate
1. Disable TLS 1.0 and 1,1 on SQL Server ******Add the following Regkeys********** [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client] "DisabledByDefault"=dword:00000001 "Enabled"=dword:00000000 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server] "DisabledByDefault"=dword:00000001 "Enabled"=dword:00000000 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client] "DisabledByDefault"=dword:00000001 "Enabled"=dword:00000000 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server] "DisabledByDefault"=dword:00000001 "Enabled"=dword:00000000 ********************************************** 2. Reboot server 3. Try opening Sage 100 client from workstation
Related Solutions