Error logging into OneDrive to preparing/receiving an Inventory
Description
Cause

Errors connecting to OneDrive when performing an Inventory in the Sage Fixed Assets Tracking version 2022.1 and higher when the TLS 1.0 and TLS 1.1 is disabled.

Errors include:

  • Verification Failed Unable to verify the setup of the OneDrive. Please try again.
  • Download Failed: Unable to download file from the OneDrive folder. Please try again.
  • Unable to Connect to OneDrive 
  • Verification Failed Unable to verify the setup of the OneDrive. Please try again. 
  • Download Failed: Unable to download file from the OneDrive folder. Please try again. 
  • Error connecting to OneDrive when TLS 1.0 is disabled

For Sage Fixed Assets Tracking version 2021.1 and prior the dll file in the hotfix from Error on downloading Inventory to Android Device is also needed.

Resolution

To connect to OneDrive through Tracking with the TLS 1.0 disabled on the client:

 

 

  1. Close all Sage Fixed Assets applications or utilities on the system.
  2. Go to Regedit and browse to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.Net Framework\, right click the v 4.0.30319, select New, DWORD (32-bit) Value and enter SchUseStrongCrypto as the new name
  3. Right click the new SchUseStrongCrypto name, select Modify and enter 1 as the Value Data, select Hexadecimal use base and click OK
  4. Open the Sage Fixed Asset Tracking and then Prepare/Receive the inventory from the Mobile Device.

If the Error continues, see Error: “Unable to access OneDrive service”


[BCB:165:Chat Fixed Assets US:ECB]






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