How to clear ghost connections
Description

This may appear as "Your license allows up to X users to access Sage Fixed Assets. It is currently accessed by X users".

Cause

The most common causes for lingering Sybase connections are:

  • The local System account does not have Full Control of the Share under Sharing\Permissions
  • When connecting across sub-nets and if the Path to the system Database (Bestsys.db) is an UNC path. This path should be a local relative drive letter. Changing the path to the server relative drive letter to the Bestsys.db will provide a more stable connection
    Example: C\SFAServ\Bestsys.db
  • Client program task was force closed on a remote system

These ghost or phantom connections will cause errors during tasks, including: 

  • You may not edit company "X" while other users are accessing its data 
  • You may not backup company "X" while other users are accessing its data 
  • You are licensed for "X" users, you currently have "X" users in the system 
  • Project is being used by another user
Resolution
Warning: This workaround will clear all active connections to Database Engine on the server. All existing Depreciation - Network client connections will be terminated. All users currently in the Depreciation - Network client should close the client while this fix is applied.


Note:

  1. Right-click the Database Utility - Network Depreciation and Tracking in the Start menu. Select Run as administrator.
    Alternatively: In Windows Explorer browse to C:\SFAServ\Common\ then right click fassvcmgr.exe and select Run as administrator.
  2. Click Service Manager.
  3. Click Stop.
  4. Wait 10 seconds, then click Start.
  5. Click Close and Exit to close the utility.

[BCB:165:Chat Fixed Assets US:ECB]




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