Error: "This program has quit. You cannot connect to the pervasive database engine. [TS 2695]" (drive mapped to server does not use servername)
Description
Cause
  • The drive mapped to the server does not use the server name
  • Workstation installation used the server IP address instead of the server name when installing through UNC path
  • Workstation installed using IPv4, mapped drive or FQDN instead of UNC
Resolution
[BCB:3:Network warning:ECB]

Review the registry values to verify they use the Computer Name instead of IP address or Fully Qualified Computer Name:

There are four string values located in the following registry key:

32 bit Operating Systems - HKEY_LOCAL_MACHINE\SOFTWARE\Timberline\General
64 bit Operating Systems - HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Timberline\General

The string values that should not reference a IP address or mapped drive:


Accounting Server: [Server Name]
Application Data Directory: \\ [Server Name]\Timberline Office\9.5
Documents Directory: \\ [Server Name]\Timberline Office\9.5\Documents
Shared Server Key: \\ [Server Name]\Timberline Office\9.5\Shared


Note: These paths contain the default share name (called Timberline Office) for the Timberline Office folder on the server, which is automatically shared out during the Accounting Server installation. The share name may be different, depending on if you have renamed the share name or not.

If a IP address or Fully Qualified Computer Name is referenced in the path select one of the following solutions:

  • Uninstall the workstation and reinstall from \\ [Server Name]\Timberline Office\9.5\Accounting\Wininst\Install.exe
  • Manually modify the paths to use the computer name.
Steps to duplicate
Related Solutions