Error: Service Management returned the following error: Unable to process transaction. Unable to locate the specified time entry. Employee [Employee ID].
Description
Cause
  • This error may be returned due to file locations set incorrectly in the Payroll Data folder in cases where the Payroll data is stored in a different folder than the Service Management data files.
  • This issue can also be caused by changing a flat rate work order register item in Service Management after the check has been created in Payroll.
  • In a multiple user environment it is possible that one operator can delete a labor related item from the work order register while another is sending time to Payroll. The SM Time Entry is the last record to be updated as posted to Payroll during the Service Management Post Time Entries task. Service Management will delete time entries from the TIMEENTRY.DAT that are not marked as posted to Payroll when a labor item is deleted from the work order register.
  • There are multiple SMData folders sending time entries to the same Payroll transaction file. When checks are being posted and/or voided in Payroll, the payroll program looks only in the active SMData folder for the time entries on the check being voided. Error is returned when Payroll can't find all of the SM related time entries that are on the check being posted or voided in the active SMData folder. (Note: This configuration is not recommended)
Resolution
  • Verify that the file locations are set appropriately in cases where the Payroll data files are not stored in the same folder as the SMData files.
  • The resolution of this issue may require a file fix. Please contact Customer Support.
Defect ID
542295
Steps to duplicate
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