Error: "Unable to process transaction. Unable to locate the specified time entry" (SM)
Description

The error isn't written to the Log Viewer when posting. The error is returned on the screen when attempting to void, post or delete the affected check.

Full error message

"Service Management returned the following error: Unable to process transaction. Unable to locate the specified time entry. Employee [Employee ID]"

Cause

Incorrect File Locations

The error occurs due to incorrect File Locations in the Payroll data folder when you store Payroll in a different folder than Service Management.

Changes in Service Management

Changes made in Service Management before you complete your Payroll can cause this error. The SM Time Entry is the last record updated as posted to Payroll during the Service Management Post Time Entries task. Service Management will delete time entries from the TIMEENTRY.DAT that aren't marked as posted to Payroll when the SM changes occur.

For example:

  • Changing a flat rate work order register item in Service Management after you create the check in Payroll
  • One user deleted a labor-related item from the work order register while another is sending time to Payroll

Using multiple SMData folders

There are multiple SMData folders sending time entries to the same Payroll transaction file. We don't recommend this configuration.

When you post or void checks in Payroll, it only looks in the active SMData folder for the time entries on the check. The error occurs when Payroll can't find the SM-related time entries in the active SMData folder.

Resolution

File Locations

In cases where you don't store Payroll and SMData in the same folder, verify that you have the correct File Locations set up.

Other causes

Other causes may require a file fix to resolve. Contact Sage Support for assistance.

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