Slow performance of Sage 300 Construction and Real Estate after migration
Description
Cause

This can be caused by references to inaccessible or invalid company folder paths stored in the company list file and security.

Specifically:

  1. When performing a migration using the older method of creating registry keys on the new server, there is a step that requires removing old company folders from the Open Company window. If this step is not performed (i.e. the old server crashed and there was never a chance to complete this step, or it was overlooked), on the new server, if the new server has a different computer name and share paths, these symptoms will be present.
  2. This can also be caused by deleting old company folders or moving/cutting and pasting the folders, such as through Windows Explorer, without first properly removing the data folder from the Open Company window. If you manipulate the data folders in Windows Explorer without removing the data folder from the Open Company window first, Sage 300 will still reference the old path, or incorrect paths.

If caused by File Locations entries referencing a decommissioned Server:
NOTE: Perform the steps below for all companies

  1. Log into Sage 300 CRE Desktop
  2. Select Applications tab
  3. Select Common Task, File, Company Settings, File Locations
  4. Find and update any entries referencing the old Server
  5. Select Ok
  6. (If applicable) Repeat Steps 2-4 for the rest of your companies

NOTE: If you're upgrading from 16.x or older, where you owned or installed a module you no longer own, contact Sage Support for assistance in verifying there isn't a file location entry for that module.

Resolution

Contact Sage Support for assistance removing references to data folders that do not exist anymore or have invalid paths.


[BCB:156:Chat 300 CRE US:ECB]
Defect ID
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