MyAssistant tasks are not sending emails (ISD services need to be restarted)
Description

Cause
  • You need to restart the MyAssistant ISD services (ISDAdminSenderService and ISDAdminTaskService)
  • You may have restarted the Pervasive/Actian services, or the services restarted during an update. If the Pervasive/Actian services restart on the file server, you must also restart the ISD services, in that order
Resolution
[BCB:5:Third-party support:ECB]

 

You may see the following errors messages in relation to the emails not sending:
  • Event Viewer on the server may show one of these errors:
    • An exception occurred reading the Sage 300 CRE log.
    • Unable to open table: QLM_MASTER__LOG --->
    • System.Data.Odbc.OdbcException: ERROR [HY000] [Simba][SimbaEngine ODBC Driver][DRM File Library]Disk I/O error.
  • Email received with message:
    An error occurred reading Sage 300 CRE data for task [task name] on data folder [data folder name].
    Confirm the MyAssistant Configuration and Task Condition is setup correctly.
    Error: DataDriverException (31740) table or view not found: [path to data file].

To resolve the errors:

Restart the MyAssistant ISD services using MyAssistant Designer (Version 20.3.5 and greater):

  1. Open MyAssistant Designer.
  2. Go to File, Restart Run and Send.
  3. Click OK.

Restart the MyAssistant ISD services using Configuration Manager:

  1. Log on the server as an administrator.
  2. Launch MyAssistant Configuration Manager.
  3. Click OK to close out of the MyAssistant Configuration Manager window. This automatically restarts the ISD services. This may take a minute or two.

Note: When you activate the MyAssistant server license, it associates that Windows profile with the server license. When you log unto the server as a different Windows profile, you may receive activation errors. You must log in as the Windows profile who performed the original activation.

Restart Services with Windows Services.MSC:

  1. Log on the server as an administrator.
  2. Click the Windows start menu, Run (or the Search programs and files field in newer operating systems), and type: services.msc.
  3. Press Enter. This will bring up the Services window.
  4. Locate the ISDAdminSenderService and ISDAdminTaskService to right-click and restart both services.


[BCB:156:Chat 300 CRE US:ECB]


Steps to duplicate
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