Error: "Data is not selected for reporting printing" when printing Sales Order Invoices
Description
Cause
  • Invoice selection criteria issue
  • Invoices were already printed
  • Print Invoices checkbox not checked in Invoice Defaults
  • User specific issue
Resolution
[BCB:1:Backup warning:ECB]
  • Invoice Selection
    • Confirm the Invoice selection criteria
    • In the Invoice Number field operand, select Contains and define a specific invoice number.
  • Invoices were already printed
    On the Sales Order Invoice Printing screen, click Print Invoices Already Printed

  • Print Invoices checkbox not checked in Invoice Defaults
    • Expand Modules, Sales Order, Main
    • Double-click Invoice Data Entry
    • Click the Defaults button
    • Select the Print Invoices check box, and click OK
    • Print the sales order invoice

 

  • Issue occurs only with a specific user
    1. Create a new user account and test
    2. If the issue occurs only with a certain user ID, you can delete and re-activate the user ID:
    • Expand Modules, Library MasterMain
    • Double-click User Maintenance
    • Use the User Logon lookup button to select the user receiving the error message
    • Click Delete
    • Click Yes to the prompt Do you want to delete user xxx?
    • In the User Logon field, type the user code for the deleted user
    • Click Yes to the prompt The user xxx has been deleted. Do you want to re-activate this user?
    • From the Company list, select a company for the user
    • From the Role list, select a role for the user
    • Click Accept
Defect ID
Steps to duplicate
Related Articles