Slow performance in Sage products (incorrect network adapter duplex settings)
Description

If you are also running other Internet Integrated applications/hardware like VoIP, please ensure the Ethernet cable is the correct type of cable.

Please check with your IT Professional for more information or to check your current network configuration.

  • Cat5 cable can handle up to 10/100 Mbps at a 100MHz bandwidth
  • Cat6 cables can handle up to 10 Gigabits of data, that bandwidth is limited to 164 feet — anything beyond that will rapidly decay to only 1 Gigabit (the same as Cat5E).
  • Cat6A is the newest iteration and utilizes an exceptionally thick plastic casing that helps further reduce crosstalk.
    • The biggest distinguishing difference between Cat6 and Cat6A cables is that Cat6A can maintain 10 Gigabit speeds for the full 328 feet of Ethernet cable.
Cause
If the duplex or link setting for the network adapter is set to any type of "auto", this may cause slow network performance and affect Sage products.
Resolution

[BCB:3:Network warning:ECB]

 

[BCB:5:Third-party support:ECB]

 

  1. Log on the Sage Application server as an administrator.
  2. Access your Network Connections window. Your operating system and your Windows settings determine what exact workflow needed to access the Network Connections window. Consult with your network administrator.
    • Right-click Network and select Properties, and click Change adapter setting, or open Control Panel, Network and Sharing, Change adapter settings
  3. Locate the correct network adapter connection used to communicate with the accounting clients, right-click and select Properties.
  4. Click the Configure button.
  5. Click the Advanced tab.
  6. Locate and click the setting for "duplex" or "link speed". Every network card is different so the name may differ slightly, but should generally have the word "duplex" or "link speed" in it.
  7. Once you have the duplex setting highlighted, you should see the available values. Any value set to "auto" or "automatic" may cause the network card to take more time trying to determine what speed it should run at, which results in slow network performance. Make a note of this value, but do not change it.
  8. Consultant your network administrator and have the network administrator make the appropriate change to select a value other than "auto".
    • Note: What exact value is selected depends on many factors, such as if the network card, the network switches/routers, the Ethernet cable and any other applicable network device communicates at a specific speed, such as 100 Mbps full duplex speed, or at some other factor. This is for your network administrator to identify and decide. This decision is not up to Sage.
    • WARNING: If you change the values incorrectly and one or more devices in your network cannot handle a specific speed or setting, your network connection may cease to operate! Consult your network administrator before proceeding!
  9. After verifying these settings on the server, log on the workstation as an administrator and perform the same steps. Networks require two-way communication.

Note:

  • In many cases, you can test the network performance by copying a folder from the workstation to the server, and from the server back to the workstation. A folder about 50MB in size should take roughly 10 to 15 seconds to complete the transfer. If you see the message that it will take a couple of minutes, then you have a network issue that's causing Sage products to be slow.
  • This test must be done from the workstation to the server, and from the server back to the workstation, meaning you will copy the data from the workstation to the server, and then from the server right back to the workstation. Networks require two-way communication. Performing only one test (i.e. copying from workstation to server, but not from server to workstation) is not a valid test and is not meaningful.
  • Run this copy test before and after duplex or link speed settings modifications to compare results.
Steps to duplicate
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