Error: "This program has quit. You cannot connect to the Pervasive/Actian database engine. [TS 2695]" (Firewall blocking Pervasive ports)
Description
Cause

The firewall on the server is blocking the Pervasive/Actian engine on the workstations from connecting.

If everything was previously working and suddenly everyone is receiving this error, the Local Area Network (LAN) settings may have been incorrectly changed to Public from Domain, Private, or Work. There have been reported cases of Windows updates changing this setting. When the value is set to Public, Windows Firewall will behave entirely differently and start blocking all sorts of Pervasive/Actian connection attempts.

Workstation was installed with the Fully Qualified Domain Name instead of the UNC path. (Ex: Server01.dom.Local instead of Server01) for the Application Data Directory et. al.

Resolution
[BCB:3:Network warning:ECB]

Note: The easiest way to verify if a firewall is causing the issue is to disable the firewall (Windows Firewall or any other 3rd party firewall you're using) completely and try opening Sage 300 CRE on the workstations again. If it opens normally, the firewall(s) is the cause of the issue. You can do one of two things:

  • If it's never worked and you are trying to get everything working for the first time, your firewall will need to be configured properly to allow the following ports.
    1. Open the following ports (i.e. set exclusions) on the server firewall. These ports are required for proper authentication (through named pipes):
      • Port 3351 , TCP
      • Port 1583 , TCP
      • Ports 137-139 , UDP
    2. Try starting Sage 300 CRE on the workstations to verify it now works.
  • If everything was previously working and suddenly everyone is now receiving this error, the Local Area Network (LAN) settings may have been incorrectly changed to Public either by someone or by Windows updates.
    1. Click the Windows start menu, right-click on Network and select Properties.
      • Note: If you do not see Network, open Control Panel instead and look for and click on Network and Sharing Center or View network status and tasks (depending on your view settings in Control Panel).
    2. Immediately on the center screen, you will see your network. If it shows up as "Public network", and you are not on a public network (i.e. coffee shop, airport), click on Public network and change it to Work network or Domain network, depending on the options available and what network you are really on.
    3. Verify that you can now launch Sage 300 CRE on the workstations.
    4. If the workstations still cannot connect, you may need to manually set exclusions as noted in the above section.
  • If the Registry Editor shows the FQDN (Fully Qualified Domain Name) for the server instead of the UNC path then reinstall the client using the UNC path instead of the FQDN.
    1. ​​​​​​​​​​​​​​You can tell what was used in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Timberline\General
DocLink: What firewall port exceptions to set for Sage 300 CRE?

[BCB:156:Chat 300 CRE US:ECB]
Defect ID
Steps to duplicate
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