Error: "A protection device or license is required" (LM) (server lost its licenses) (Pervasive)
Description
Note: As of September 30, 2018, replacement keys/dongles are no longer available.
Cause

The License Manager server lost its licenses. This can be due to not adding the license files to the server's license file, a corrupt license file, or malfunctioning license service when the server reboots.

If you are unable to resolve with one of the options below, and the issue happens frequently, contact Sage support to report the problem and prepare to troubleshoot with a Sage support analyst. The analyst will need access to the License Manager server, a user with administrator access, and a reboot of the server may be required.

Resolution
Note: License Manager is used on all Sage Estimating Pervasive versions and includes Sage Estimating SQL versions up to 16.11.


Option I: Add licenses to the "To the Server and its File"

  1. Log on the License Manager (LM) server as an administrator.
  2. Launch WlmAdmin.exe (located on the Estimating install download or image under \AdditionalInstalls\LicenseManager\Admin.net\Win32\)
    • If you do not know where the Estimating install files are, see article below on how to find it. You must find the correct version of the files that matches your current install. Do not use files from a newer or older version of Sage Estimating.
  3. Expand Subnet Servers by clicking the [+] sign next to it.
  4. Right-click the computer name of the LM server, select Add Feature, From a File, To Server and Its File.
  5. In the next window, in the Look in dropdown, browse to C:\Program Files (x86)\Common Files\Safenet Sentinel\Sentinel RMS License Manager\WinNT\ and select the lservrc file, and click Open.
    • Note: for a 32-bit version of Windows, search in Program Files instead of Program Files (x86).
  6. After clicking Open, a message should pop up confirming X number of licenses were added successfully. Try launching your Estimating applications again. If you receive errors at any point, contact Sage support.

Option II: Delete the corrupt lservrc file and re-add the features

  1. In Windows Explorer, browse to C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\WinNT
  2. Delete or rename lserverc
  3. Add the licenses following instructions in Option I above.

Option III: In a virtual environment using USB over IP device

Since the USB key must be present when the Sentinel RMS License Manager service starts in order for the licenses to load properly, you may need to set the service to start after all the other services have loaded. Using delayed start may also resolve this issue even when not in a virtual environment since another service may be interfering with the proper functioning of the LM service.

  1. Launch the Windows Services control panel
  2. Double-click the Sentinel RMS License Manager service
  3. On the General tab, Startup type option, choose "Automatic (Delayed Start)"
  4. Click OK


[BCB:164:Chat Estimating US:ECB]

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Steps to duplicate
Related Solutions

Error: "A protection device or license is required" (Master List) (Pervasive)