Error: "Prefix incompatible with balance sheet level."
Description

Cause

This error occurs when you try to use an income statement prefix with a balance sheet base account.

If the prefix is correct but the account you want to use is incorrect, see the solution below. If your prefix is incorrect, you may need a key change to correct your prefix. Contact your Sage consultant to verify whether your prefixes are set up correctly.

Resolution

Balance Sheet account types in General Ledger:

  • Current Assets
  • Noncurrent Assets
  • Current Liabilities
  • Noncurrent Liabilities
  • Equity
  • Retained Earnings

Balance sheet prefixes are prefixes that have zeroes for each prefix after the balance sheet level prefix

Examples of Balance Sheet prefixes:

  • ABC Prefix with Balance Sheet at A:
  • 01-00-00
  • All balance sheet accounts would need to have the prefix 01-00-00.
  • ABC Prefix with Balance Sheet Level at B:
  • 01-10-00
  • All balance sheet accounts would need to have the prefix 01-10-00
  • AB Prefix with balance sheet level at A:
  • 01-00
  • All balance sheet accounts would need to have the prefix 01-00

If the account you are using is one of the balance sheet account types, it can only be used with the correct balance sheet prefixes.

Verify the account you want to use is set up correctly:

  1. Go to General Ledger, Setup, Accounts.
  2. Enter the account or click List to select it from the list.
  3. Verify that the prefixes for the account are correct.
    Note: Contact your Sage consultant if you need assistance in verifying whether your prefixes are incorrect. If your business partner determines that your prefixes were set up incorrectly, contact Customer Support. You may need a key change to correct your prefixes.
  4. Under Account Type, verify the account type is correct. Correct the account type if it is incorrect.
  5. Click Save and Close if you made any changes; otherwise, click Cancel.

Note: if you do not have access to General Ledger, Setup, Accounts select General Ledger, Inquiry, Account to veify the information. Add a oolumn to the inquiry view to show the Account Type. Refer to KB 20006 DocLink: How do I add or edit a column in an inquiry? for information on how to add a column to the inquiry. If the full account does not exist, select General Ledger, Reports, Lists, Base Accounts to determine what account type is set on the base account.

See the link below for more information on prefixes and how General Ledger generates accounts.

DocLink: How does General Ledger generate accounts?
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