How to manage Custom Fields with multiple databases
Description
Cause

You need the order and process for adding custom fields to test and create reports, and then when completed, be able to apply the same change to a Production database. Assumption that the test data-set simply another company off the same server that currently houses the Production data.

Resolution

Sage highly recommends that all custom fields in one company folder exists in all company folders. This is the expected state for custom fields and the software will attempt to add those custom fields to each data folder, either by prompting the user to upgrade all folders once a custom field has been added to one folder or automatically the next time that a data upgrade is performed. The custom fields in the dictionaries between the standard dictionaries (…Timberline Office\9.5\Accounting\DICT) and the dictionaries in the actual data (example datafolder\PVData\master_jcm\jcm.dct) should always be in sync. To deliberately manipulate these files in an attempt to keep custom fields unique per data folder is not supported and could lead to dictionary corruption or loss of data.

If custom fields are added to the test folder to create and test a report, it will prompt you to upgrade other folders. For the purposes of this test, you can say no to the prompt to upgrade the other folders for now and continue your test, knowing that if you inadvertently upgrade the Production data or run a File Doctor with fix and compact or compact good files checked, you will populate the Production folder with those custom fields.

If you add custom fields in your test company and either deliberately or inadvertently add those fields to other data folders, be sure to run upgrade files on the other folders if you decide to remove the custom fields from your test folder.

One thing to note, if that if you create a report based on these added custom fields, then delete those fields and attempt to re-add them, it is likely that the report you created may no longer work. Re-adding a custom field may add it back to the dictionary with a different index number.

When moving terminated employees (with the Move Employees option), Custom fileds will not be moved if the destination Payroll master file is created at the time the employees are being moved, or if the destination Payroll master file has not been set up and upgraded to include the Employee Custom fields that exist in the source Payroll master file.

Defect ID
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