Cannot print a Sage 100 report or form to a specific printer tray
Description


Cause

Note: Examples of actual problems with printer tray or manual feed selection that customers have encountered:

  1. A physical printer had an obstructed tray (that could not be seen upon casual inspection).
  2. There was no paper in the desired tray, or the printer's internal mechanisms were not working properly (did not recognize that there was paper in the desired tray, or could not grab paper from the desired tray).
  3. An obsolete printer driver was installed and being used. The commands for tray selection were not understood by the printer.
  4. A generic printer driver or a driver for a different printer model was being used to control a specific printer.
  5. A printer driver for a printer by manufacturer A was being used to control a printer for a different manufacturer B. Regular printing (without specifying tray selection) worked only because both manufacturer shared some base programming (many are based on standards set decades ago by laser jet manufacturer HP (Hewlett-Packard)), but tray selection commands sent using the driver from manufacturer A could not be understood by manufacturer B's printer, so was ignored.
  6. Desired tray was Tray 3. Printer driver was incorrect and didn't offer the option of Tray 3, only Trays 1 and 2.
Resolution

 NOTE: Printer drivers differ in their capabilities. Not all printers are capable of tray selection. Not all printer drivers are capable of receiving input from Sage 100 to print to a particular tray. Sage 100 Customer Support offers the following suggestions based on what has worked for some customers in the past, but cannot guarantee success. Sage 100 Customer Support suggests working with your Sage business partner or IT profssional for trial-and-error testing or troubleshooting of tray selection problems.

If the correct tray had been working before, try to reset the Print Spooler:

  1. In Windows, Control Panel, Administrative Tools, Services:
  2. Right-click on Print Spooler service. Stop it.
  3. After it stops, right-click it again select Restart
  4. Try printing again.

 TIP: If Use Multi-part printing is selected when printing a form then it will only show multi-part enabled/configured printers and other printers will not appear. You can test with another Form Code which does not have multi-part printing selected. 

Otherwise, try the following (this is essentially trial and error):

  • Install a new printer driver for the physical printer, and set (via Printer Preferences) the default tray desired. The name of the new printer can include the default tray number to differentiate it from another instance of the printer driver.
  • When on the report or form printing task window, select the specific physical printer, then click the "Setup" button, select the specific printer, and go into Printer Preferences to select the desired tray number.
  • Edit the report for form via Crystal Reports Designer (the correct version of Crystal Designer compatible with the version of Sage 100 must be installed on the workstation), such that in Page Setup, the "No Printer" check box is selected. Or, try specifying the printer in Page Setup. Save the form or report.
  • Try installing a different printer driver, such as a generic PCL6 driver.
  • For graphical (Crystal Report) forms or reports, consider enabling Mulit-Part Printing even if only one printer will be used to print to a particular tray.

[BCB:155:Chat 100 US:ECB]
Steps to duplicate
Related Solutions

How to add the Designer button to report or form printing task windows (to launch Crystal Reports Designer)
Cannot print to a thermal or label printer (such as a Dymo or Zebra or Brother QL series)
How to setup and use Multi-Part Form Printing in Sage 100
How to troubleshoot printing problems in Sage 100