Error: "Failed to retrieve data from the database". (Service Management DSN is corrupt)
Description
Cause

Corrupted Data Source (DSNs)

Resolution

[BCB:3:Network warning:ECB]

 

Delete the SM data DSNs, and then set them up again.

Note: Please verify that you have full control on all required permissions before you proceed with the following solution. Refer to the attachment below for considerations.

 

  1. Prepare to delete the DSNs:
    1. Have all operators exit Service Management.
    2. Log on to the server with the following permissions:
      • Network Administrator
      • Timberline Accounting Unlimited (privileged) operator
  2. Delete the SM data DSNs from the User DSN and System DSN tabs in the ODBC Data Source Administrator.
    1. From the Windows task bar, click Start, All Programs, ODBC, 32bit ODBC Administrator.
    2. Click the User DSN tab.
    3. Select the Timberline SM Data DSN.
    4. Click Remove and then click Yes to confirm.
    5. Click the System DSN tab.
    6. Select the SM[hexadecimal number] DSN.
    7. Click Remove. and then click Yes to confirm.
    8. If you have more than one SM[hexadecimal number] DSN, delete each one following steps 2.f-2.g.
  3. Open up the Control Center by going to:
    • 16.1 to 24.1: Start, All Programs, Actian PSQL 12, PSQL Control Center & documentation
    • 24.2 and later: Start, All Programs, Actian Zen 15, Zen Control Center & documentation
  4. Expand Engines in the folders on the left and you should see your Server name.
  5. Expand Databases and you should see all your DSNs.
  6. Delete all the SM DSNs (example: SM79C8EDD9E4AB54) by right clicking on the DSN and select Delete, choose "Yes, but only database name".
  7. Once you have deleted all the SM DSNs close out of the Pervasive Control Center.
  8. Browse out to C:\ProgramData\Pervasive Software\PSQL or C:\ProgramData\Actian\PSQL and rename the DBNAMES.CFG file to OLDDBNAMES.CFG.
  9. Start Service Management and follow the steps below to automatically recreate the database connection.
    Note: You will follow these steps for all your company data folders even if you did not have any issues with your other company data folders.
  10. Start TS-Main or Sage Desktop, and then start Service Management.
  11. Go to Reports, Work Orders, Work orders in progress. This report creates the data connection between server and workstation.
  12. You should now be able to process as usual in Service Management.
Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the Database" (Troubleshooting)