Error: "Failed to retrieve data from the database". (corrupt Service Management DSN)
Description
Cause

Corrupted Data Source Name (DSNs)

Resolution
[BCB:3:Network warning:ECB]

 

Delete the SM data DSNs, and then set them up again. Verify that you have full control on all required permissions before you proceed with the following solution.

  1. Have all operators exit Service Management.
  2. Log on to the server with the following permissions:
    • Network Administrator
    • Sage 300 CRE Accounting Unlimited (privileged) operator
  3. Delete the SM DSNs from the User DSN and System DSN tabs in the ODBC Data Source Administrator.
    1. From the Windows task bar, click Start, All Programs, ODBC, 32bit ODBC Administrator.
    2. Click the User DSN tab.
    3. Select the Timberline SM Data DSN.
    4. Click Remove and then click Yes to confirm.
    5. Click the System DSN tab.
    6. Select the SM[hexadecimal number] DSN.
    7. Click Remove and then click Yes to confirm.
    8. If you have more than one SM[hexadecimal number] DSN, delete each DSN following steps 3.f-3.g.
  4. Open up the Control Center by going to:
    • 16.1 to 24.1: Start, All Programs, Actian PSQL 12, PSQL Control Center & documentation
    • 24.2 and later: Start, All Programs, Actian Zen 15, Zen Control Center & documentation
  5. Expand Engines in the folders on the left and confirm you see your server name.
  6. Expand Databases and confirm you see all your DSNs.
  7. Delete all the SM DSNs (example: SM79C8EDD9E4AB54) by right-clicking the DSN, selecting Delete, then choosing "Yes, but only database name".
  8. When you've deleted all the SM DSNs, close out of the Pervasive Control Center/Zen Control Center.
  9. Browse out to C:\ProgramData\Pervasive Software\PSQL or C:\ProgramData\Actian\PSQL and rename the DBNAMES.CFG file to OLDDBNAMES.CFG.
  10. Launch Service Management.
  11. Go to Reports, Work Orders, Work orders in progress. This report creates the data connection between server and workstation.
  12. Repeat Step 12 for all companies in Service Management.
  13. Confirm Service Management works as normal.
Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the Database" (Troubleshooting)