How do I remove unwanted entries from the New.blt file?
Description
Cause
  • Entries associated with contract-based jobs sent to Billing in error
  • The contract doesn’t include the required information to move entries from the new.blt file to the unbilled.blw
Resolution

Important: Only apply these steps to remove unwanted entries from the new.blt file.

Verify transactions

  1. Create a backup of your data. See How do I use File Tools to back up data files?
  2. From the Billing Inquiry menu, select Transactions.
  3. Review the inquiry for any transactions you need to generate for active cost-based contracts.
  4. If you need to generate entries, go to Tasks, Cost-Based Invoices, Generate Work-In-Progress.
  5. Generate invoices as needed to retain correct transactions.
  6. Check the Transactions inquiry again and confirm that only unwanted entries remain.
  7. Choose one option below:
    • If only unwanted entries exist in the new.blt, rename the file
    • If other entries remain that you can’t generate, create a dummy contract or item for the entries

 

Rename the New.blt file

Remove the entries by renaming the New.blt file with File Tools. For more information, see How do I rename a file using File Tools?

Notes:

Perform this process monthly or quarterly to remove unwanted items to avoid a backlog.

The first time you post a cost it will generate a message that the new.blt file doesn’t exist. Instruct users to say yes to create as long as it references new.blt.

Create a dummy contract or contract item

  1. In Contracts:
    1. Create a new cost-based contract or add a contract item to an existing cost-based contract. Don’t change the Status to Approved to complete these steps. Leave the status as Proposed.
    2. Link one or more contract items to the Job, Extra, Cost Code and/or Categories associated with the rejecting entries.
  2. In Billing:
    1. Run Tasks, Cost-Based Invoices, Generate Work-In-Progress.
    2. Select Conditions to add conditions to generate work in progress for a specific job or contract.
    3. Be sure to save and review the BL Generate WIP Journal.
    4. Verify that all entries generated that previously rejected.
  3. In Contracts:
    1. Open the "dummy" contract/contract item.
    2. Select the Billing tab and change the Billing type to a Contract-based type of contract.
    3. Clear the Send cost to Billing check box.
  4. In Billing:
    1. Run Tasks, Cost-Based Invoices, Regenerate Work-In-Progress.
    2. Select Conditions to add conditions for a specific job or contract.
    3. Check the journal for a message related to the unwanted entries. They should be deleted or the status changed to Rejected.
  5. In Contracts:
    1. Open the dummy contract.
    2. Delete the contract items you created for the fix.
Steps to duplicate
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