Error: "This directory does not currently contain any data"
Description


Cause
  • The folder was created "on the fly" during a move task.or while utilizing a tool and does not contain a ts.ctl file
  • The ts.ctl was accidentally deleted
Resolution

IMPORTANT NOTE: Do not use this solution to add a company folder that was formerly on the list of folders, but has disappeared. This solution applies only to adding new folders that were not previously on the list in Open Company.

Option 1: Restore ts.ctl from backup. See How do I restore individual files from backup without using file tools (Pervasive)?

Option 2: Create a ts.ctl file for use in the company folder

When you archive data, for example by moving jobs or by moving transactions from history to history, the folder containing the archive data does not contain a ts.ctl file. If you later want to open the archive folder from FileOpen Company, the folder will not be in your list until you create a ts.ctl file for that folder. You will do this by creating a new temporary company folder and then copying the ts.ctl file from the new folder to the archive folder.

Warning: Do not copy the ts.ctl file from your actual live data folder to your archive data folder as this could cause security failures. Instead, follow the steps below to create a new folder and then copy the ts.ctl from the new folder to the archive.

  1. In your live data folder, go to File, New Company.
  2. Type in a name, for example TEMPLATE, press TAB, and then click OK.
    Important: Do not clear the Use current setup check box because this selection copies sections for the GL account, JC jobs and cost codes, AR invoices, CN contracts and items, from your live folder to the new folder. If Use Current Setup is not selected you will need to correct custom descriptions to match prior settings before copying the ts.ctl file. This is not recommended, as it may result in errors and prevent the system from working correctly.
  3. Use File Tools to copy the ts.ctl file from your new temporary folder to your archive folder.
  4. Open your archive folder by going to File, Open Company and clicking Specify Folders.
  5. If desired, remove TEMPLATE from the list of folders in Open Company as follows:
    1. Go to File, Open Company.
    2. Right-click the folder you want to remove and select Remove from list.
    3. Click OK.
Steps to duplicate
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