Obsolete or non-existing printers show in printers list in Sage 100
Description

Delete 'stale' printer objects from workstation

https://social.technet.microsoft.com/Forums/windows/en-US/e3b08893-962d-461c-a698-09427164b6c1/delete-stale-printer-objects-from-workstation?forum=w7itpronetworking

Cause

Redirected printers may be a result of other remote users and printer redirection.

Microsoft Windows contains the information on the obsolete printer connections in one or more of the following Windows Registry keys:

  • [HKEY_CURRENT_USER\Printers\Settings]
  • [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Devices]
  • [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\PrinterPorts]
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers]
  • [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers]
  • [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\Control\ Print\Printers]
  • [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows NT\CurrentVersion\Devices]
  • [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows NT\CurrentVersion\PrinterPorts]
  • [HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers]

Printers may be missing if user does not see printer in Windows when logged into Terminal Server.

(there may be group policy or other process to connect/map printers but does not show for a specific user when logged in to Terminal Server)

Resolution
  • Redirected printers may be a result of other remote users and printer redirection
    • The other users may need to unselect Printers from their Local Resources on their remote connections
  • For non-"redirected" printers, the issue is a Microsoft Windows related issue
    • Stop and restart the Windows Print Spooler in Services
    • Restart the workstation, if it has not been restarted already
    • If this does not resolve the issue, then it may require editing the Windows Registry to remove references to the obsolete printers:
      • Changes to the Windows Registry are not supported by Sage Software, the information below is based on results from Microsoft articles:
  1. Select Start, Run
  2. Type Regedit to edit the Windows Registry
  3. Backup the existing Windows Registry
  4. Edit the following Windows Registry key and delete the references to the non-existent printers:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Devices

See Additional Information regarding Deleting 'stale' printer objects from workstation for more information.

If printer is "missing" or does not appear in Sage 100 printers list, confirm that the printer does show in Windows Devices & Printers for that user that is logged into Terminal Server. If missing in Windows printers list will need to resolve that before it appears in Sage 100.

DocLink: How to troubleshoot printing problems in Sage 100
Defect ID
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