Error: data object cannot be opened/accessed. Database Connector Error: "Data Object cannot be opened/accessed. Failed to retrieve data from the database. Error in File [ReportName] {string}.rpt: the table could not be found." (In Service Management)
Description
Cause

The Pervasive Client Engine does not support usage of DDF files for Crystal reporting. This was a change effective in Sage 300 CRE Versions 15.1 and greater.

Reports still using DDF files to retrieve data that are no longer valid.

Resolution
  1. Download the attached .zip file below and save to your system. Extract them to \\YourServerName\Timberline Office\9.5\Accounting\Report\Service Management.
  2. Look at the list of reports in the folder and backup same reports in customers service management report folder in case they have customized any of these reports.
  3. Copy the reports from the SM DSN Reports folder you extracted and put them in the service management report folder on the customers computer after backing theirs up.

DocLink: Error: "Failed to retrieve data from the Database" (Troubleshooting)
Attachment: 400_20230425124221_SM DSN reports.zip
Defect ID
540603
Steps to duplicate
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