Error: "File [ReportName] {string}.rpt: the table could not be found" (Service Management)
Description
I receive errors when running certain Service Management reports on a workstation. The same reports run without error on the server.
Cause
In Sage 300 CRE versions 15.1 and later, the Pervasive/Actian/Zen Client Engine doesn’t support usage of DDF files for Crystal reporting.
Reports still using DDF files to retrieve data that are no longer valid.
Resolution
Download the attached .zip file below and save to your system.
Extract the files to an accessible location. The extracted folder will have the name SM DSN reports.
Note the list of reports in the folder.
Browse to \\YourServerName\Timberline Office\9.5\Accounting\Report\Service Management.
Replace YourServerName with the name of your Sage 300 CRE server.
Locate those same report names in your Service Management report folder and save copies. This retains a backup of the reports in case you've customized any of them.
Copy the reports from the SM DSN reports folder you extracted.
Paste them into the Report\Service Management folder.
Test the reports in Service Management and confirm you no longer receive an error.