Error: "Data is not Selected for Report Printing" when printing statement for a customer with open invoices
Description
Cause
Selections are preventing customer selected to print.
OR
The CustomerStatus$ field is blank in the AR_Customer file. A status of A (Active), I (Inactive) or T (Temporary) is required for all customers
Resolution
[BCB:1:Backup warning:ECB]

First check the Selections section in Statement Printing for possible criteria that is preventing the statement from printing. You may need to scroll down in this section to see all of the fields available to select.

If the above did not resolve the issue, manually edit AR_Customer.m4t via DFDM or refresh the Customer Status in Customer Maintenance.

  1. Open Sage 100 and navigate to Library Master, Utilities, Data File Display and Maintenance
  2. Click OK to bypass the Warning message
  3. In the File Name, type AR_Customer
  4. In the KPRIMARY/Key, type the division number followed by the customer number
  5. Press Enter or the Key Scan to search for the record
  6. Click the Edit button and select the drop-down to type A, I, or T in the CustomerStatus$ field

Refresh the customer status in Customer Maintenance

  1. Open Accounts Receivable, Main, Customer Maintenance
  2. In the Customer No. field, select or enter the customer in question
  3. Go to the Additional tab, in the Customer Status drop-down, change the status to Temporary
  4. Click Accept
  5. Reselect the customer again
  6. Go to the Additional tab and change the customer status back to Active
  7. Click Accept
  8. Rerun Statement Printing


[BCB:155:Chat 100 US:ECB]
Defect ID
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