INTERNAL: Why are there Unposted Payroll checks in Cash Management? (Reprinted check or regenerated direct deposit for terminated employee)
Description

This issue is resolved in Sage 300 Construction and Real Estate version 18.4.1. Previously if you reprinted a check for a terminated employee, the original check was not voided in Cash Management. Now when you reprint the check (using the same check number or a new check number), the original check is voided.

Cause

Checks reprinted with different check numbers that are associated with employee(s) with a termination date set on their Employee record where the Terminated employee warning level is set to "Soft warning" in the Payroll settings will result in this issue where the original check is not voided or deleted from the Cash Management register.

When attempting to reprint a check from a new PR transaction file that is associated with an employee that has been terminated using the same check number that was assigned to the check fails to reprint. The following error message is returned: "Duplicate Check transaction for Bank "XYZ" found in register. Employee ABC."

The check can be reprinted successfully by assigning a different check number when the Terminated employee warning level is set to "Soft warning" in the Payroll settings. Reprinting the check results in both the original and new check numbers existing in Cash Management, where the original check number no longer exists in Payroll.

Issue has been duplicated in Sage 300 CRE Versions 13.1 through 18.3.1.

To avoid this issue, clear the termination date set on the employee before reprinting the check, then add it back once the check has been reprinted successfully.

Resolution

A workaround can be used to resolve this when there are 5 checks or fewer that need correction and none of the transactions are direct deposits.

If there are more then 5 payroll checks that need correction, contact support for assistance. While the fix is being completed, no other users can be in the software. The user must be a full rights user, and able to use File Tools.

If the cause of this issue is that the new.prt file was deleted, this maybe a billable file fix.

This issue is being evaluated by Product Development for resolution in a future release.

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