Nightly backups and maintenance aren't running
Description
Cause
  • The NT AUTHORITY\SYSTEM account doesn't have the correct permissions assigned
  • The Sage 100 Contractor folder permissions have been changed
  • The nightly maintenance task isn't running under the System account
  • The nightly backup schedule conflicts with another backup application
  • The \\Sage100Con\Temp folder contains extra files
  • The server is in sleep or hibernate mode during the nightly backup schedule
  • The server's hard drive has little free disk space available

 

Resolution

Multiple reasons can contribute to this issue; review them in the order listed below.

NT AUTHORITY\SYSTEM lacks the correct permissions

  1. Open Microsoft SQL Server Tools on the server.
  2. Open Microsoft SQL Server Management Studio on the server.
  3. Choose the instance for Sage 100 Contractor in the Server name picklist.
  4. Click Connect.
  5. Expand Security in the Object Explorer panel.
  6. Expand Logins.
  7. Right-click NT AUTHORITY\SYSTEM.  Select Properties.
  8. Click Server Roles, on the left.
  9. Select the boxes for public and sysadmin.
  10. Click OK.
  11. Close Microsoft SQL Server Management Studio.

Restore changed folder permissions

  1. Ensure your file folder permissions match those noted in File shares and permissions.
  2. Connect to Sage 100 Contractor Database Administration
  3. Click Toolbox and Server Tools
  4. Click Restore permissions for the Sage 100 Contractor file system
  5. Click Restore Permissions

The nightly maintenance task isn't running under the System account

  1. Press the Windows key + R to open the Run dialog.
  2. Type "taskschd.msc".  Press enter.
  3. Expand the Task Scheduler Library, on the left.
  4. Click Sage 100 Contractor.
  5. Right-click the name of the nightly scheduled task, on the right.  Select Properties.
  6. Verify the nightly maintenance task is running on the System user account.

The nightly backup schedule conflicts with another backup application

  1. Press the Windows key + R to open the Run dialog.
  2. Type "taskschd.msc".  Press enter.
  3. Expand the Task Scheduler Library, on the left.
  4. Review the Task Scheduler Library's other third-party backup tasks.
  5. Review and adjust the timing of other scheduled backup tasks to avoid conflicts.

The \\Sage100Con\Temp folder contains extra files

  1. Open Windows File Explorer on the server.
  2. Click View on the menu.
  3. Click Show and Hidden items.
  4. Browse to [Installation Drive]: \Sage100Con\Temp.
  5. Ensure the only file in this location is Description.txt.
  6. Delete all files from this location except for Description.txt.

The server is in sleep or hibernate mode during the nightly backup schedule

  1. Press the Windows key + R to open the Run dialog.
  2. type "control" and press enter.
  3. Select Power Options.
  4. Click Change plan settings next to your selected power plan.
  5. Click Change advanced power settings.
  6. Expand the Sleep section.
  7. Under Sleep, choose Never.
  8. Expand the Hibernate section.
  9. Set Hibernate after to Never.

The server's hard drive has little free disk space available

Ensure the server has enough free disk space. Review the recommended system requirements.

[BCB:154:Chat 100 Contractor US:ECB]

 

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