Nightly backups and maintenance are not running
Description

Nightly backups and maintenance are not running

Cause

Backup failures occur on your Sage 100 Contractor server. They may involve logins and passwords, disk space, file folder permissions, and computer power settings.

If you know that the NT AUTHORITY\SYSTEM account was formerly a sysadmin and now is not, some possible causes include:

  • In Database Administration, someone manually un-checked the sysadmin checkbox.
  • Someone uninstalled and reinstalled 100 Contractor on the server.
  • Someone created a new SQL Server instance. (By default, a new instance’s SYSTEM account is not a sysadmin.)
  • You updated from a version prior to 21.2 that did not offer this option.
  • A Windows or SQL Server update made an unexpected change. Environmental changes can affect the SYSTEM role. SYSTEM needs to be a sysadmin if the server is a domain controller. Otherwise, SYSTEM may not have needed to be a sysadmin in the past, but that has now changed. Sage 100 Contractor and Database Administration have not changed in any way that would affect this account.
Resolution

Please use these troubleshooting instructions. Note that Section 2 Step 1 has different steps depending on your version number.

.

Before you begin detailed troubleshooting:

  1. Access the server you are using for your 100 Contractor data. You will perform these troubleshooting steps on the server.
  2. Open SADMB_LastResultsLog.txt. Its usual location is C:\Sage100Con\Backup\Nightly\.
  3. If there are no messages in SADMB_LastResultsLog.txt or its messages are not helpful, look at the SQL Server’s file ERRORLOG. Its usual location is C:\Program Files\Microsoft SQL Server\MSSQL12.SAGE100CON\MSSQL\Log\.
  4. Check whether your file folder permissions match those in the article DocLink: File Permissions and File Shares for the Sage 100 Contractor File System (Sage100Con). You can revert to the required permissions using Database Administration - Toolbox - Server Tools - Restore permissions for the Sage 100 Contractor file system.
  5. Ensure your server has sufficient disk space for Sage to back up your data and store the newly created .ZIP file.
  6. Ensure your 100 Contractor attachments folders are not too large. If they are large, Step 3 explains how to increase the time allowed for the backup task. For more information, see DocLink: Where are attachments located, is it too large or how to decrease the attachments folder size?
  7. In the server's Windows settings, check whether your computer is set to sleep or hibernate during specific hours or when you are inactive. The backup task cannot “wake" the computer, so you must schedule it when the computer is running as usual.
  8. Rule out timing conflicts. If the steps below show that you can manually run the task, ask IT whether other process that run overnight may be conflicting with the backups. If you there are such tasks, you can change your backup schedule to avoid conflicts with them.

Note: Some of the following steps require use of a Microsoft utility (outside of Sage). Be careful not to change settings other than the ones described; other changes could damage your company data. If you are unsure about any of these steps, contact Live Chat and ask for a phone analyst to call and assist you.

.

Section 1: Delete and recreate the nightly maintenance schedule(s).

  1. Open Database Administration.
  2. Choose Schedule Nightly Maintenance, then Remove Maintenance Schedules.
  3. Select the company for which the backup is failing, then choose Remove Schedule.
  4. Choose Create Maintenance Schedules.
  5. Select the same company, choose a time and number of backups to keep, and then choose Save Schedule.

Note: The backup task you just recreated will use SYSTEM to log in. Leave this “as is” and go on to Section B.

.

Section 2: Verify the following items:

1. Make the SYSTEM account a SQL administrator

If you use version 21 or later, use these steps:

  1. Open Database Administration.
  2. Choose Company Admins/SQL Logins, then Modify SQL Server Administrators.
  3. In the list of logins, put a check next to the box for NT AUTHORITY\SYSTEM.
  4. Click Update sysadmins.
  5. Note: If the NT AUTHORITY\SYSTEM account was previously marked as a sysadmin and now is not, see Additional information below for possible causes.

If you use version 20, use these steps:

  1. From your Windows Start Menu, locate the program folder Microsoft SQL Server 2014 or 2016. Expand this folder and open SQL Server Management Studio 2014.
    Note: You can also find this utility in C:\Users\Public\Documents\Sage Support Console\Sage 100 Contractor\06 - SQL Server 2014 Management Studio.
  2. Open this utility using a login that has access to the company data. This Is usually the same one you used in Section A, Step 1, above.
  3. In the left-hand column, expand the Security folder and then the Logins folder.
  4. Find the login NT AUTHORITY\SYSTEM. Right-click on it and choose Properties.
  5. In this window, click Server Roles.
  6. Check the sysadmin checkbox.
  7. Choose OK
  8. Close SQL Server Management Studio.

2. Make sure the Sage100con\Temp folder contains only Description.txt.

Temp is a hidden folder. (If you do not see it, in File Explorer, choose View and click Hidden Items.) For backups to succeed, Temp must contain only the file description.txt. Other files can appear here when a backup fails, or when someone is troubleshooting backup issues and cancels a process in Windows Task Manager.

3. In Task Scheduler, check the Settings tab.

If your backup takes three hours to run, but your task times out at two hours, the task will fail. Here is the fix:

  1. Open the Windows Task Scheduler by typing Task Scheduler (in Windows 10) or using Control Panel - Administrative Tools - Task Scheduler (in prior versions of Windows).
  2. On the left, expand Task Scheduler Library and click on the folder named Sage 100 Contractor.
  3. In the list of tasks, find and double-click on the task for your database's maintenance schedule. (A description of each task is in the lower pane.)
  4. In the task’s window, click the Settings tab. Check Stop the Task if it runs longer than and choose the number of hours needed. Click OK.
  5. To test this fix, manually run the maintenance task. Right-click the task name and choose Run. Follow the progress of the task through each of these file locations:

C:\Program Files\Microsoft SQL Server\MSSQL12.SAGE100CON\MSSQL\Backup
[data drive]:\Sage100Con\Temp
[data drive]:\Sage100Con\Backup\Nightly

Now, check the Nightly folder for the presence of your backup file. You can also verify the results by opening SADMB_LastResultsLog.txt.

IMPORTANT: If the file does not move through these steps, then a more significant problem is preventing the backups. Contact Live Chat and explain which steps you have already tried.

.

Section 3: Tune Up your data

  1. From the server, open Database Administration.
  2. Click Tune Up/Back Up/Restore and then Tune Up Databases.
  3. Put a check mark next to the name of each company that you are backing up. Choose Run Tune Up.

During the Tune Up, errors mean that you have found the cause of the backups failing. Each scheduled backup task begins with a Tune Up. If the Tune Up fails to complete, the main backup task cannot start. Contact Live Chat for further assistance.



[BCB:154:Chat 100 Contractor US:ECB]


Steps to duplicate
Related Solutions

How to create an On-Demand backup in Sage 100 Contractor SQL
How to create SQL or Windows Authenticated users and Company Administrators