Error: "Failed to retrieve data from the database... Vendor Code: 31740" (previewing Billing invoices)
Description
Cause

Temporary data sources used to preview Crystal Reports didn't get removed. We’re researching causes for this issue.

This can occur due to subreports in the BLNP and BLCP files. The error only occurs when opened from the Billing application. Instead, launch Contract-Based Invoices or Invoice Formats from the Sage Desktop.

Resolution

Choose an option below to resolve the error.

Clear locked temporary data sources

  1. Close the preview window and close all Sage applications.
  2. Go to the Windows Start, All Programs, ODBC.
  3. Choose the correct administrator and tab for your version.
    • Versions 25.2 and earlier: 32-bit ODBC Administrator, User DSN tab
    • Versions 26.1 and later: 64-bit ODBC Administrator, System DSN tab
  4. On the correct tab, select any Timberline_Temp_XXXXX_X data sources and click Remove.
  5. Repeat for all Timberline_Temp_XXXX_X data sources.
  6. Launch Billing and preview your invoice as normal.

Use a design-based invoice format

  1. From the Billing Tools Menu, select Invoice Formats.
  2. Select the invoice format assigned to the contract.
  3. Click [...]
  4. Select a billing invoice design file.
  5. Click Close.

Alternate option

If this only occurs for one contract, you can try deleting and recreating that contract.

Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from database" when previewing Billing invoice (Error in BLNP.crs or BLCP.crs)

Error: "Failed to retrieve data from the Database" (Troubleshooting)