Error: "Failed to retrieve data from the database Details: [Database Vendor Code: 31740]" (previewing an invoice in Billing)
Description
Cause
Temporary data sources used to preview Crystal Reports did not get removed.
Resolution

Option 1 - Clear locked temporary data sources:

  1. Close the preview window and close all Sage applications.
  2. From the Windows Start menu, Select All Programs, ODBC, 32 Bit ODBC Administrator

    or if this is a 64-bit machine, browse to C:Windows\sysWOW64\odbcad32.exe.

  3. Select any Timberline_Temp_XXXXX_X data sources and click Remove.
  4. Repeat for all Timberline_Temp_XXXX_X data sources.
  5. Launch Billing and preview your invoice as normal.

Option 2 - Use a design based invoice format:

  1. From the Billing Tools Menu, select Invoice Formats.
  2. Select the invoice format assigned to the contract.
  3. Click [...]
  4. Select a billing invoice design file.
  5. Click Close.

We are researching causes for this issue.

NOTE: 

  • If this occurs for one contract, the contract may need to be deleted.
  • This may be related to subreports in the BLNP and BLCP and error only occurs when opened from the Billing application.  Instead, launch Contract based Invoices or Invoice Formats from the Sage Desktop.


Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from database" when previewing Billing invoice (Error in BLNP.crs or BLCP.crs)
Error: "Failed to retrieve data from the Database" (Troubleshooting)