How to resolve "One or more files could not be copied..." message received during Sage 100 Workstation Synchronization
Description

Note: a similar copy error message can occur during an upgrade to 2020 or later if a an older version's MAS90 folder is copied to the new server without an installation done and you attempt to access that older MAS90 data by launching that pvxwin32.exe and then typing "run startup.m4p" (MAS90 /Standard mode) as the workstation synchronization could trigger and then an "error when copying files" message appear.

In this case, you may need to create the Common Components folder manually on the new server used for Sage 100 2020+ in the location where pre-2020 install workstation synchronization looks for that data:

  • C:\Program Files (x86)\Common Files\Sage\Common Components (64 bit system)
  • C:\Program Files\Common Files\Sage\Common Components (32 bit system)
  • In Sage 100 2020+ the common components folder is relocated to C:\ProgramData\Sage\Common Components\

Additional note: Antivirus software can also interfere with the Workstation Synchronization and cause the "one or more files could not be copied" (or no/incomplete results during Workstation Synchronization and it loops over and over).

One specific example:antivirus software that creates a virtual location as a CONTAINMENT object (\VTROOT\C$\ location) when anything that does not have an exception (like the autoupdate script) run - for example: Comodo Client Security 12. Disabling the ‘containment’ piece of Comodo allowed the script to work and the files to get updated.

Cause
Beginning with Sage 100 Standard 2018.4 and higher, after the installation of a Product Update or an update to Payroll 2.x (Sage 100 Versions 2018 and higher), during initial workstation launch after update, Sage 100 will detect if updated files need to be copied to the Sage 100 Workstation and perform the copy. Should the update of any files fail, Sage 100 will display the following message:
Note the name of the log file that is referenced, AutoUpdate.6.00.mas.log.txt or AutoUpdate 6.00.Payroll.Log.txt. Click OK

Note: the name of the log file that is referenced, AutoUpdate.6.00.mas.log.txt or AutoUpdate 6.00.Payroll.Log.txt. Click OK.

Failed copy attempts need to be resolved on the Sage 100 Workstation receiving the message to avoid errors or unexpected results. The most common reason for failed update attempts is that one or more files are in use or locked on the workstation. Under normal circumstances, this would be unexpected, but it can occur if orphaned pvxwin32.exe sessions or other external processes are running. Examining the log file mentioned in the message above, you will see a list of all the files copied, their location, and which one (s) failed.

You may also have this issue occur if the log indicates "Create folder failed! Invalid procedure call or argument" which may be due to a missing/corrupt Temp folder or access is not available to the Windows temp location folder.
Resolution
Option I: Make sure user opening Sage 100 client has FULL permissions to ' C:\Program Files (x86)\Common Files\Sage\'
  1. Browse to C:\Program Files (x86)\Common Files\ (C:\ProgramData\ for version 2020 or higher) )folder
  2. Right-cick 'Sage' folder and select Properties\
  3. Select Security tab
  4. Click Advanced
  5. Verify the user has FULL control to current folder and subfolder and files
    NOTE: (if applicable) Give the current user Full control to folder
  6. Click OK until Properties window is closed
  7. Try opening Sage 100 workstation client again

Option II:
  1. Close Sage 100 if it is running on the Workstation
  2. Rename or delete the following file(s) located in the Workstations
    • C:\Program Files (x86)\Common Files\Sage\Common Components (64 bit system)
    • C:\Program Files\Common Files\Sage\Common Components (32 bit system)
    • C:\ProgramData\Sage\Common Components\ (version 2020 or higher)
      • autoupdater.6.00.ini or autoupdater.6.10.ini
      • autoupdater6.00.payroll.ini or autoupdater.6.10.payroll.ini (if you have Payroll 2.0)
      • AutoUpdate.6.00.mas.Log.txt or AutoUpdate.6.10.mas.Log.txt
      • AutoUpdate.6.00.payroll.Log.txt or AutoUpdate.6.10.payroll.Log.txt (if you have Payroll 2.0)
  3. Restart (restart) the Workstation. This will clear unexpected processes that may be preventing one or more files from being updated
  4. Start Sage 100. Workstation Synchronization should begin. if no further errors are received, you can login to Sage 100 and process.

In most cases the above will resolve the issue. If the above steps do not resolve the issue, you can manually attempt to update the problematic files.

  1. Take note of the file names that are not being updated (found in the AutoUpdate.6.00.mas.log.txt or AutoUpdate.6.00.Payroll.Log.txt file(s))
  2. On the Sage 100 Server, locate the ..\Mas90\Home\Lib\_repository folder. Inside you will see one or more folders for each Product Update and / or Payroll Version that was installed
  3. In the example above Sage 100 2018.4 (6.00.04.00) was the latest update installed. Search this folder for the file(s) that did not update (refer to the ..log.txt files), and manually copy them to the Sage 100 Workstation replacing the existing file
DocLink: Error: "One or more files was not updated" or "Workstation update failed"

[BCB:155:Chat 100 US:ECB]
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