Error: "This program has quit. I/O Error. Pervasive status code 3012" (Actian/Pervasive status in Services is "Starting")
Description
Cause

After a Windows update, both the status for Relational and Transactional engines are stuck in "Starting".

Resolution


On the Workstation:

  1. Search for Services.
  2. Right click on the PSQL Relational Engine.
  3. Select Properties.
  4. Select the Startup type as Automatic (Delayed Start).
  5. Click OK.
  6. Right click on the PSQL Transactional Engine.
  7. Select Properties.
  8. Select the Startup type as Automatic (Delayed Start).
  9. Click OK.
  10. Close the Services window.
  11. Reboot the Workstation.


[BCB:164:Chat Estimating US:ECB]

Steps to duplicate
Related Solutions