Unable to preview Sage 100 Reports
Description
Cause

Conflicting Crystal Report Files due to multiple Crystal Reports Installations

Resolution

This usually means there's a conflicting version of Crystal Reports or Crystal Runtime also on the system.

Be sure to uninstall older versions of Crystal Reports and/or Crystal Reports runtimes.

  1. Uninstall existing Crystal Reports
  2. Rename the following folders if they still exist:
    1. C:\Program Files (x86)\Common Files\Crystal Decisions 
    2. C:\Program Files (x86)\Crystal Decisions\ 
  3. Uninstall/Reinstall SAP Crystal Reports runtime Engine
    1. In Sage 100 2023 or higher:
      • Open Program (Apps) and Features
      • Uninstall 'SAP Crystal Reports runtime engine for .NET Framework (32-bit) and (64-bit)
      • (if running Sage 100 32-bit) Browse to ...\MAS90\wksetup\Prerequisites\CrystalRuntime
      • Double-click 'CR13SP30MSI32_0-10010309.MSI' to install a 32-bit version of Crystal Runtime
      • (if running Sage 100 64-bit) Double-click 'CR13SP30MSI64_0-10010309.MSI' to install the 64-bit version of Crystal Runtime                                                                                     NOTE: In some environments, run the .MSI file using 'run as administrator' to avoid errors.
         
    2. In Sage 100 2022 or older: Uninstall/Reinstall the Sage 100 client.
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