Error: "Sage 50 update could not be completed and needs to be run again."
Description
Cause
  • Files are in use
  • The existing installation of Sage 50 on the computer is damaged
Resolution

Disable SmartPosting and stop Actian Zen

  1. Click the Windows Start button, and in the Search field, type services.
  2. Type Services. Right-click Services and select Run as administrator.
  3. In the Services window, right-click Actian Zen Workgroup Engine and select Stop.
  4. Scroll down to Sage 50 SmartPosting 20xx. Right-click it and select Properties.
  5. Change the Startup type to Disabled.
  6. Click Stop and then click OK.
  7. Close the Services menu, then try installing the update again.

If the update still fails, uninstall and reinstall Sage 50 Accounting using the latest full install package, which contains the latest update build:

Uninstall and reinstall

  1. Download the latest full product release (which includes the patch update) from the Sage 50—U.S. Edition: Download Portal.
  2. Go to Control PanelPrograms and Features, and uninstall Sage 50 Accounting.
    • If there’s a notice saying that you can't uninstall because Sage is still running on the computer: Open Task Manager and go to Details and end Peachw.exe
  3. Reinstall Sage 50 Accounting from the new download. For installation steps, see How to install Sage 50 Accounting.
[BCB:161:Chat 50 US:ECB]

 

Steps to duplicate
Related Solutions