Payslips fail to upload to Sage HR
Description
Cause
  • Wrong accounting period
  • Duplicate paychecks
  • Problem on employee records
  • Paychecks need to be re-saved
  • Paychecks need to be re-entered

 

Resolution

 NOTE: Log in to the Sage 50 company as the data owner.

 NOTE: The checks must have a check number and an amount. By design, $0.00 dollar paychecks won’t upload payslips to Sage HR.


Duplicate paychecks

Multiple paychecks with the same amount on the same date for the same employee are flagged as duplicates and won't upload to Sage HR. For instance, say there were two paychecks dated May 10 in the amount of $505.30 for employee ALLEN. The first check uploads as a payslip to Sage HR, but the second check won't show. This is functioning as designed, and is part of the duplicate detection system in Sage HR, which is there for your protection.

If this situation does arise, the workaround is to change the date on the check that failed to the day before or the day after. Then sync payslips to Sage HR, and it will upload. After that, then change the date on the check entered in Sage 50 back to the original date.

 TIP: If the problem checks aren't duplicates, have an amount, and you’re logged in as the data owner, continue to the troubleshooting steps below. 


Make sure you're in the current accounting period

  1. Click the period in the upper right corner or go to Tasks > System > Change Accounting Period.
  2. If the accounting period is in a different period than the paychecks that are being sent, select the correct period and click OK.
  3. Click No to Would you like to print your reports before continuing? If you’re prompted to run an Internal Accounting Review, select No.
  4. Try uploading the payslips again.

Check employee records

Open the employee in Maintain Employees & Sales Reps and make sure that in the Address there are no special characters such as:

  • backslash:  \
  • left brace:  {   
  • right brace:  }   
  • caret:  ^

If present, remove or replace these characters and save the record. 

Also verify on the employee records that the Primary Email exists and that the Sage HR checkbox has a check mark.

If the Primary Email is missing, correct it and save the employee records. Then upload the payslips again.

If the payslips don’t upload, toggle Sage HR off and on for the affected employees.

  1. Go to Maintain, Employees & Sales Reps and select the employee.
  2. Uncheck the Sage HR (payslips and forms) box and click Save.
  3. At the prompt, select Turn off sync but keep employee record in Sage HR and click OK.
  4. Check the Sage HR (payslips and forms) box and click Save.
  5. Upload the payslips.

If the payslips still don’t upload, continue to the next section.


Re-save the problem paychecks

  1. Open up any paychecks that didn’t upload as a payslip to Sage HR. Click the Save button again.
  2. Upload payslips again.
  3. Verify in Sage HR that the payslips uploaded successfully. If not, continue to the next section.

Delete and re-enter the problem paychecks

  1. Delete the paychecks that won’t upload.
  2. Re-enter the paychecks with the same reference numbers as before.
  3. Upload payslips and verify that the payslips appear in Sage HR now.

Using Direct Deposit

You can’t delete transmitted Direct Deposit checks. We recommend uploading payslips to Sage HR before running the WebSync Wizard to transmit Direct Deposit checks. That way if there’s an issue with the payslip upload, you can address it, and then sync the Direct Deposit checks.

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Steps to duplicate
Related Solutions

How to upload payslips to Sage HR