Payroll direct deposit is rejected by my bank (Canadian Direct Deposit)
Description
Cause

Royal Bank of Canada (RBC)

Royal Bank of Canada requires additional information be written to the ACH file when uploading to the banks web site or FTP SSL site. Sage 300 CRE Accounts Payable does not create this information at this time.

RBC Royal Bank format (see Appendix 2) https://www.rbcroyalbank.com/ach/file-451771.pdf

The bank does not conform to the Standard 005 file format. https://www.payments.ca/sites/default/files/standard005eng.pdf

 

Bank of Montreal

The file encoding type is not saved as an ANSI type.

 

Scotiabank

The bank rejects the file:

FILE REJECTED
YOUR FILE HAS FAILED STRUCTURAL VALIDATION CHECKS FOR THE FOLLOWING REASONS.
[number] payment(s) failed during enrichment for the following reason [No Customer-Channel association found for the Sender ID [xxxxxxxxxx] , Channel ID [xxxxxx], Matching Key [CPRA], Payment Type [EFT], Matching Routing Code/Account Number [xxxxxxxx], Matching Out Country Code [CA], Matching Out Currency Code []]

Resolution

Royal Bank of Canada (RBC)

Currently the solution is to manually enter the information to the bank web site.

Bank of Montreal

Before uploading the file to the bank, open the file in Notepad, select FileSave As, and select the Encoding type as ANSI then click Save. Then send that file to the bank.

Notes: 

  • You may also need to mark Include optional hard return in Options in the Generate Electronic Payments task when generating
  • You may be able to change the default character encoding for Notepad in the registry settings - consult with your IT network administrator about this

Scotiabank

  • The Returns Account Information is missing in Options in the Generate Electronic Payments task when generating.
  • Mark the Include optional hard return check box in Options.
  • The bank does not use the Currency Code Identifier in their file format, but it is in the CPA005 Standard format which is why it is included in the file the software creates. Before uploading the file to the bank, open the file in Notepad, and in the A record (line that begins with "A"), find CAD and replace it with spaces (3 spaces). This should be in character positions 56-58 of the A record.
Steps to duplicate
Related Solutions

AP Generate Electronic Payment file is rejected by my bank (Canadian Direct Deposit)

Which file format do the Canadian Direct Deposits and Electronic Payments use?