Error: "At least one damaged transaction has been found in account..."

Summary

How to resolve this error in Sage 50 Accounting, when running the General Ledger report.

Description

Error: "At least one damaged transaction has been found in account [number] in the period beginning [date]..."

Cause

  • Editing a transaction multiple times can cause the transaction to post incorrectly
  • Damaged transactions
  • Changing an account on a paid or partially paid vendor invoice
  • Changing an account on a paid or partially paid customer invoice

Resolution

Run data tests to try to repair the damage

Run Data Verification

  1. Change the accounting period to Period 1.
  2. Select File, and then Data Verification.
  3. Select Both Tests, and then Start.
  4. Save the backup. When the backup completes, the data tests will begin automatically.
  5. If you get the same error during the Data Verification test, skip to the Run Integrity Check section.
  6. If there aren't any errors, change the accounting period back to the current period.
  7. Run the General Ledger report. If you still receive the error, proceed to the Run Integrity Check section.

Run Integrity Check

  1. Select File, then Backup and make a backup of your company. Put before test in front of the backup name.
  2. Change accounting period to Period 1.
  3. Open the Integrity Check by going to Help, Support Utilities, Integrity Check.
  4. Select Continue.
  5. Check Reindex Files.
  6. On the Reindex Files List, select Chart and click OK.
  7. Repeat steps 2-5 reindexing the following items:
     NOTE: Perform test for each file one at a time. 
    • Customer
    • Employee
    • Vendor
    • Jrnl Header
    • Jrnl Rows

       NOTE: If the damaged transaction is in an Inventory account, include Line Item in step 7, and the Inventory / Journal test in step 8. 

  8. For each test indicated below, repeat steps 2-3, then select the indicated item and click OK:
    • Customer / Journal
    • Vendor / Journal
    • Employee / Journal
  9. Chart of Accounts / Journal
     NOTE: 
    During the Data Synchronization tests, it can flag customers, vendors and employees. Click OK to each message to continue. 
    During the Data Synchronization test for Chart of Accounts, if it flags bad transactions:
    • Either write down the Reference number for each indicated entry, or take a screenshot to note which entries it referenced
    • Delete each of the indicated problem transactions and re-enter them
    • Once you recreate the transactions, run the tests again to verify that no further synchronization errors occur

If the error no longer occurs, it’s advisable to create a new backup of the company.

If the error still occurs, restore a backup made before the error occurred.

Converted data from Intuit QuickBooks

  • If you receive the error after converting from QuickBooks, it indicates the data didn’t convert correctly
  • View the IntuitConversion.log file to see what went wrong. Repair the data in QuickBooks, and then convert the data again
  • See the guide Sage 50 Accounting U.S. Edition Converting from QuickBooks

Consolidated company displays error

  1. Run Data Verification as outlined in the Run Data Verification section in all subsidiary companies. If the error continues in any subsidiary company, refer to the Run Integrity Check section.
  2. Afterwards, reconsolidate the consolidated company.
  3. If the problem persists, create a new consolidated company.
  4. Add one company at a time to see which one is causing the problem.

Related Solutions

Integrity Check Guide
How do I consolidate multiple companies for reporting purposes?
How do I reconsolidate my consolidated company?

Solution Properties

Solution ID
220924350010369
Last Modified Date
Thu Jul 10 13:55:35 UTC 2025
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