Summary
Employee photo missing after upgrade in Sage HRMS
Employee photos are blank
Cannot view employee photo
Employee photos are missing
Description
Cause
- Employee photos do not meet the system requirements
- Permission issues
- Employee photos are over 1 mb file size
- The name of the file for the photo is longer then 50 characters
Resolution
CAUTION: These steps require knowledge of your Sage product's database engines, such as Microsoft SQL Server, Pervasive SQL, and MySQL. Sage can't assist with database administration and isn't responsible for errors resulting from database changes. Back up all system and application databases needed for a complete restore, and consider contacting a certified consultant or your database administrator for assistance.
The following information was provide in the Sage HRMS 2016 Product Release Notes about product enhancement made to employee photos and what to consider in order for Sage HRMS to allow photos to be viewable in Sage HRMS:
- Each single file photo size must be at a maximum 1 mb or less.
- The photo files must exist in \\Server\SageHRMSSserver\Data\Photo folder
- Ensure Sage HRMS network client user have full permission on the above path
- Photos must be in the supported file format as noted below
- The name of the employee photo file being attached must be less then 50 characters in length
- If a photo is missing its likely did not meet one of the above crateria. Update the photo format according to instructions below
We also applied new attachment technology to your employee photos. Your current employee photos (added prior to this release) are automatically updated with this release so the photos can display on the employee record. The photos are limited 1 MB file size (each) and must be a PNG, JPG, JPEG or GIF file type.
Note: It's possible that some of your photos may not convert, depending on the file type and file size. We recommend you review each employee, verify that the photos are displayed.