Skip to content
logo Knowledgebase

Exclude Sage 100 from antivirus real-time scans

Created on  | Last modified on 

Summary

How to exclude Sage 100 from antivirus, real-time scans.

Description

This information helps to minimize interference by security programs when working.

Cause

Antivirus software is targeting or interfering with the functionality of a program, system, or data files for Sage 100. Issues include lockups, "error #0" record/file busy errors, error #12 "files doesn’t exist (or already exists)" and slow performance.

Errors during installation of Sage 100 or Sage 100 workstation could mention SY_installationObject, cm_UDTListingWrk.M4T, cm_detailreportwrk.m4t, etc. with file name changing on different attempts.  These occur due to files locked by the antivirus real-time scan.

Resolution

 CAUTION: This solution requires advanced knowledge of Windows security and network settings. Sage isn't responsible for any issues that arise from changes to these settings. Ensure you back up all system and application databases necessary for a complete restoration. It's advisable to contact a certified consultant or your system administrator for assistance.

 

 NOTE: Watch out for antivirus products installed on the physical server hosting a virtualized server running Sage 100. Watch out for firmware-based (or other) antivirus installed on routers, across VPNs, in the cloud.

Sage Intelligence Workstations

  • Add.SDF file type and local folder to exclusions for workstations. This avoids "Access to the path 'C:\Users\xxxx\AppData\Local\Alchemex (Pty) Ltd\TempFiles\alcworker_638112906898412190.sdf' is denied"
  • Temporarily disable your antivirus product to see if this improves performance: speed file locking problems encountered, error messages, etc.
  • If performance improves, exclude the Sage 100 programs, folders, and file extensions from your Antivirus program

 

In your Antivirus product

  • Turn off aggressive or continuous scanning of Sage 100. This includes on-access, constant, or network scanning
  • Exclude these executable files: "..\MAS90\Home\Pvxwin32.exe", "..\MAS90\Home\pvxiosvr.exe", "..\MAS90\Launcher\Launch32.exe", "..\MAS90\Launcher\Launcher.old.exe"
  • Exclude the "..\MAS90" folder, including all sub-folders and files on the Sage 100 server
  • Repeat the exclusions on workstations using Sage 100 Advanced or Premium. Default path: C:\Sage\Sage 100 Workstation\
  • Exclude PDF folders used by Paperless Office if you're using Paperless Office
  • Exclude these folders on Sage 100cloud workstations
    • Crystal Reports folder: C:\Program Files (x86)\SAP BusinessObjects
    • Common Components
  • Exclude the "Sage 100" folder in the Windows user's Documents folder
  • Exclude this path: "C:\Users\Windows_Username\AppData\Local\Temp\_autoupdater\" Replace Windows_Username with the actual Windows account name
  • Exclude these file extensions:
    •  AUC
    • DCL
    • DD,
    • DDE
    • DDF
    • EXP
    • LCK
    • LIB
    • KDF
    • M4D
    • M4L
    • M4P
    • M4T
    • M4X
    • PRM
    • PVC
    • PVX
    • RPT
    • SOA
    • XEQ
  • Add Spa.NA.Com as a trusted site

Keep in mind settings for exclusion settings take time to sync in multi-tiered environments such as a cloud-based antivirus solution.

Need more help?

Chat now