Description
Batch server tasks intermittently fail with ECONNRESET error
For example, looking in the batch server log file for a failed job ( RQT*.tra ) you can see the following text:
#AdxVL@(#)%I% Batch query log FUNAUTINVD
0001 05-28-20 09:02:32 ERROR : read ECONNRESET (10001)
NOTE: For BEST performance, Environments should be utilizing the LATEST AVAILABLE Runtime and ADXAdmin components.
Cause
For customers with the X3 Runtime service on a different server to the Syracuse service, the standard Windows TCP settings may not be suitable for the network load and performance
Resolution
CAUTION: This solution needs advanced Operating System knowledge. Consult your system administrator for help. Sage isn't liable for issues caused by improper changes to the Windows Registry. Always back up your data before applying advanced solutions.
Issue can be mitigated by adjusting the KeepAlive and SharedSection Windows Registry Setting.
See related resources for guidance on how to adjust the KeepAlive and SharedSection configuration settings in Windows Registry Editor.
Note: these settings are modifying Windows Operating System and should be handled with proper precaution.
Centre of Excellence wrote an article on the subject: Fix X3 ECONNRESET/ECONNREFUSED issue by changing Windows Heap memory - Centre of Excellence and Expertise - Sage X3 Global Hub
DocLink: Microsoft Windows timeout session allocation (KeepAlive) configuration guidelines for Sage X3 Environments
DocLink: Microsoft Windows Heap Memory allocation (SharedSection) configuration guidelines for Sage X3 Environments