Unable to save changes. One or more of the following permissions(s) are currently not supported: EWS.AccessAsUser.All.

Summary

Exchange Integration fails at the step 2 with the message . MSG : Invalid credentials, com.sage.scrm.syncengine.exchange.ews.service.error.SageExchangeServiceException: javax.xml.ws.WebServiceException: Could not send Message. 401

Description

Cause

The EWS.AccessAsUser.All is missing in the Azure Active Directory Azure App Registration.

When trying it Error: "Unable to save changes. One or more of the following permission(s) are currently not supported: EWS.AccessAsUser.All. Please remove these permission(s) and retry your request."

Resolution

Per the Admin guide the Supported Account type for Exchange is Accounts in any organizational directory (Any Azure AD directory - Multitenant)

While for Email Configuration/Management the Supported Account type is Accounts in any organizational directory (Any Azure AD directory - Multitenant) and personal Microsoft accounts (e.g. Skype, Xbox).

For Exchange Integration setup, please create a separate App Registration in the Azure Active Directory with Supported Account type for Exchange is Accounts in any organizational directory (Any Azure AD directory - Multitenant) and try to add EWS to that.

Solution Properties

Solution ID
221924560117216
Last Modified Date
Fri Feb 23 20:49:40 UTC 2024
Views
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