Error: "Connection failed: SQLState: '08001' " occurs when creating an ODBC connection on Microsoft SQL Server Express

Summary

The error occurs when creating an ODBC connection on Microsoft SQL Server Express for the Sage 300 program.

Cause

The SQL Server Express port isn’t reachable because the firewall blocks the dynamic port.
The ODBC connection doesn’t specify the correct port.

Resolution

Find the SQL Server Express port

  1. Open SQL Server Configuration Manager.
  2. Expand SQL Server Network Configuration.
  3. Select the server instance.
  4. Double-click TCP/IP.
  5. Open IP Addresses.
  6. Locate the active TCP port.

Configure your ODBC connection to use this port

  1. Open Control Panel
  2. Go to Administrative Tools
  3. Select ODBC Data Sources (64-bit) or ODBC Data Sources (32-bit)
  4. In the ODBC Data Source Administrator, select the System DSN tab

    • Add a new ODBC or select your ODBC Connection
    • Follow the prompts and enter the information
      • Name: DSN name
      •  

        Description: Optional
      •  

         

        Server: servername\instance, port (example: SERVER01\SQLEXPRESS,1433)
    • Click Finish when done
    • Test the connection to make sure the connection passes the test

     

Need more help?

Chat now

 

 

Solution Properties

Solution ID
222924450019752
Last Modified Date
Fri Mar 20 19:41:32 UTC 2026
Views
0