Desktop Launcher opens after logging in, then closes immediately with no error

Summary

When the Broadcast Shutdown flag in the SY_System.m4t file shows Y, the system prevents users from logging in. As a result, the Sage 100 Desktop Launcher opens after login but then closes immediately without displaying an error."

Cause

Also, missing datafiles in MAS90\MAS_SYSTEM post-migration can cause this issue.

Resolution

If someone broadcast a system shutdown from the Master Console but didn’t finish it, you can fix it in several ways.

  1. Find the workstation that broadcast the shutdown and press the OK button.
  2. Rename the Sage 100 folder under documents.
  3. Retrieve the ..\MAS90\MASSYSTEM\SYSystem.m4t from a recent backup, before the shutdown attempt.
  4. Access a different Sage 100 installation to open SYStem.m4t using the Data File Display and Maintenance utility. Edit the ..\MAS90\MASSYSTEM\SYSystem.m4t file in the problem installation and change the BroadcastShutdown field from Y to N.
    •  NOTE: Sage 100 Customer Support can obtain a copy of the file, edit it, then return the file 
    • Premium Version: Access the SYSystem table instead of the SYSystem.m4t and change the BroadcastShutdown column to N
  5. Rename the Sage 100 folder in the Documents folder on the workstation with the issue.

Special Case

  • If the issue happens on just one workstation, try turning off the Automatic logoff option. You can find this in the User Maintenance, Preferences tab.Automatic logoff option under the User Maintenance, Preferences tab'

Need more help?

Chat now

 

Solution Properties

Solution ID
223924250030439
Last Modified Date
Mon Apr 13 19:29:50 UTC 2026
Views
0