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Pervasive/Actian stops soon after it is started

Created on  | Last modified on 

Summary

Pervasive stops soon after it is started Actian stops soon after it is started

Description

Cause

  • Conflict with another process
  • Other process has higher priority and is causing the Pervasive or Actian service to stop

Resolution

NOTE: With Sage 50 2020 version, the Pervasive(Version 11) has been upgraded to Actian Zen(Version 13); the Service noted in the instructions below has also been renamed in Version 13:

  • For Sage 50 2019.2 and earlier the Service name is Pervasive PSQL Workgroup Engine
  • For Sage 50 2020.0 and higher the Service name has been changed to Actian PSQL Workgroup Engine

To find the process that is conflicting with Pervasive/Actian, start the computer in selective startup. See Article ID 12735: DocLink: How to boot into selective startup?

  1. Verify the Pervasive/Actian service is started and you can successfully open Sage 50—U.S. Edition.
  2. Enable one startup item and reboot
  3. Verify the Pervasive/Actian service is still running and you can successfully open Sage 50
  4. Repeat steps 3 and 4 until all startup items are enabled or until you find the startup item that is stopping the Pervasive/Actian service
  5. If you still have not found the process that is stopping Pervasive/Actian, repeat steps 3 and 4 with the services.

Workaround:

Set the Pervasive/Actian service to restart if it is stopped by another process

  1. Press WINDOWS KEY + R
  2. Type services.msc
  3. Select OK
  4. Double-click on Pervasive PSQL Workgroup Engine (or Actian PSQL Workgroup Engine)
  5. Select the Recovery tab
  6. Select Restart the Service in the First failure and Second failure drop down boxes.
  7. Click OK

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