Windows Scaling issue

Summary

Scaling issues can cause alignment issues or missing buttons in Sage Fixed Assets.

Description

Scaling issues include:

  • The Browse button is missing on step 2 of the Custom Import Helper
  • The Database dropdown is missing from the Open Company window. For example, you only see the sample companies when opening the program
  • Overlapping text
  • Text or box alignment problems in pop-up windows

Cause

Windows Display settings for Scale and Layout under Change the size of text, apps and other items is set to 125% or 150%.

Resolution

NOTE:

  • Repeat these steps for both Depreciation and Tracking if using both programs. You’ll need to reapply this fix if you uninstall and reinstall the program.
  • Close the Sage Fixed Assets product before performing these steps

For Windows 10 build 1803 and higher:

  1. Right-click on the Depreciation or Tracking icon on the desktop. Select Properties, click the Compatibility tab, select Change settings for all users, then select Change High DPI settings.
  2. Under Program DPI check Use this setting to fix scaling problems for this program instead of the one in Settings
  3. Click the Open Advanced scaling settings link below the checkbox. Set Let Windows try to fix apps so they're not blurry to Off. Click the X in the top-right corner to close the window.
  4. Under Change High DPI Settings, check Use the DPI that's set for my main display when. Set it to I signed in to Windows.
  5. Under High DPI scaling override, check Override high DPI scaling behavior. Under Scaling is performed by select System (Enhanced).
  6. Click OK, Apply and OK to save the changes.

For Windows 11:

  1. Right-click on the Depreciation or Tracking icon on the desktop. Select Properties, click the Compatibility tab, select Change settings for all users, then select Change High DPI settings.
    • If you're using a 200 or higher display font, click Change settings for all users.  Apply the same settings to the SBDDesktop.exe file.
    • SBDDESKTOP.exe is located at C:\Program Files (x86)\Common Files\Sage SBD\SBDDesktop\v14
  2. Under the Program DPI section, check "Use this to fix scaling problems for this program instead of the one in Settings".  
  3. In High DPI scaling override, check "Override high DPI scaling behavior, Scaling performed by:  System (Enhanced)". Click OK, Apply and OK.

For Windows 2019:

  1. Right-Click on the Depreciation or Tracking icon on the desktop. Select properties, click the Compatibility tab, and select Change settings for all users.
  2. In the Settings section in the Compatibility tab, click Change high DPI settings.
  3. Check Override high DPI scaling behavior. Under Scaling performed by click dropdown menu option, select System, click OK, Apply, OK.

For Remote Connection from end-user workstation to Windows server:

On the Windows server:

  1. In the Registry Editor go to:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations.
  2. Check for a DWORD-value of IgnoreClientDesktopScaleFactor.
  3. If IgnoreClientDesktopScaleFactor isn’t present, add a DWORD value with entry for the name: IgnoreClientDesktopScaleFactor.
  4. Type in a decimal value of 1, click Ok.
  5. Reboot the server to see the changes.
  6. Re-establish the remote connection to the server. Open the Sage Fixed Assets client to verify the issue no longer occurs.

 

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Solution Properties

Solution ID
225924750095633
Last Modified Date
Wed Apr 01 16:20:07 UTC 2026
Attributes
Product Information
Tier: Lite
Tier: Lite50
Tier: NW
Tier: Prem
Tier: SFA50
Tier: SU
Version: 2026-0
Version: 2026-1
Version: 2027-0
Modules: Depr
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