Summary
Connection issues when you have TLS 1.0 and/or 1.1 disabled on your SQL server for Sage Fixed Assets Premier.
Cause
You have TLS (Transport Layer Security) 1.0 and 1.1 disabled. Alternatively, you created the server without the TLS 1.0 and 1.1 enabled.
If you have TLS 1.0 and 1.1 disabled, you can encounter:
- After prompting for SA login: the BDAU hangs then prompts with the Configuration screen
- Premier Client prompting for SA login
- After clicking Next on the Configuration, the screen closes with no message
- SQL Server Error: 772
- SQL Server Error: 18
Resolution
Sage Fixed Asset Premier 2018.1 and higher support disabling TLS 1.0.
- For Premier 2018.1 - 2024.1: Ensure you installed the ODBC 11 x64 driver ENU\x64\msodbcsql.msi. Note: This driver is no longer available on the Microsoft site.
- For Premier 2025.1 and higher: Ensure you installed the ODBC 17 x64 driver. See Download Microsoft ODBC Driver 17 for SQL Server (x64) to download.
- If you install the ODBC 11 drivers and the Configuration screen continues to appear, make sure you enable the following service packs on the server:
- Microsoft SQL Enterprise, Standard or Express: Microsoft SQL Server 2014 SP3
- Any version of Microsoft SQL Server 2016, 2017, 2019, or 2022 will support disabling TLS 1.0
You need to enable TLS 1.0 and 1.1 on the SQL Server for Sage Fixed Asset Premier 2018.0 and earlier versions. This allows the Database Utilities and client systems to connect to the SQL Server by enabling these protocols.
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