Error: "Failed to retrieve data from the database" running custom Crystal Report

Summary

Error: "Failed to retrieve data..."Database Connector Error: 'S0000:[ProvideX][ODBC Driver]Internal error [Database Vendor Code: 1019 ]' when running Custom Crystal Report on Crystal Reports Designer 2020 outside of Sage 100

Cause

Selecting "Use Indexes Or Server For Speed" in Report Options has been known to cause this issue

Resolution

  • Open Crystal Reports 2020 Designer and select File, Report Options and de-select "Use Indexes Or Server For Speed" 
  • Version 2016 of Crystal Reports Designer also still works with Sage 100 ERP, versions 2023 and 2024 as an alternate option.

Note: This article was created as an informative article based on how a specific custom report was resolved to hopefully help others with same issue. Sage Support Analysts do not troubleshoot Custom Reports. If this resolution does not resolve your issue, please contact your Sage 100 Business Partner for further assistance.

Solution Properties

Solution ID
241009000342323
Last Modified Date
Wed Oct 09 00:03:42 UTC 2024
Views
0