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1099 Beginning Balance is blank after installing 1099 TY 2024 server update

Created on  | Last modified on 

Description

After an unsuccessful install of the 1099 TY 2024 Server Tax Update, customers will experience a blank 1099 Beginning Balance window when they run the 1099 Beginning Balance Task. Even if  customers start to re-enter values in the 1099 Beginning Balance Window and hit save, the values will not be saved/stored in their Sage 500 database.

Cause

The spAPTempVend1099Bal stored procedure did not get updated and has missing arguments. The following arguments/parameters should be present in the stored procedure and can be seen when you run sp_helptext spAPTempVend1099Bal in SQL Management Studio.

@iCompanyID        VARCHAR(3) 

 ,@oRetVal        INTEGER   OUTPUT 

 ,@iTaxYear        SMALLINT = 0 

 ,@iTaxForm        SMALLINT = 0 

 ,@iVendKey        INTEGER = 0 

Resolution

CAUTION: Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage business partner, network administrator, or Sage customer support analyst.

 

Prior to running/opening the 1099 Beginning Balance Task, run the following script in SQL Management Studio to mitigate the issue:
1. SELECT * INTO tapVend1099Bal_backup from tapVend1099Bal
2. SELECT * from tapVend1099Bal_backup
3. SELECT * from tapVend1099Bal
4. OPEN and COMPILE the spAPTempVend1099Bal.sql script located in C:\Program Files (x86)\Sage Software\Sage MAS 500 1099 Server Update\SP
5. Run the sp_helptext spAPTempVend1099Bal and make sure you have the five (5) arguments listed in the Cause section.

6. Run the 1099 Beginnging Balance and you should have data now

Steps to duplicate

1. Install the 1099 TY 2024 Server Update
2. Open/run the 1099 Beginning Balance

3. The 1099 Beginning Balance window will be empty/blank