Error: "I/O error in file UserPref.DAT"
Description
Cause

Userpref.dat is damaged.

Resolution
  1. If the company will open, click Maintain, Company Information; alternately, you can go to Help, Support Utilities, File Statistics. Copy or write down the Directory.
  2. Close Sage 50 on all computers.
  3. Press the Windows key + E to open File Explorer. In the File Explorer browse to the company directory.
  4. Right-click UserPref.DAT, then click Delete or select Rename and type userpref.old.
    Note: When the company is reopened, a new UserPref.DAT will be created automatically. This file contains user preferences for Sage 50, such as shortcuts or global options within Sage 50, so these settings will have to be recreated.
  5. Open Sage 50 and the company.
  6. Verify the error no longer occurs.


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