Sage Paperless Construction Error: "User is not a member of API group"
Description
Cause

Sage 100 Contractor requires the user that uses the API to be a member of the API Group in Security.

Resolution

Identify which user is set for the vault in Sage Paperless Construction:

  1. Have an administrator log in to Sage Paperless Construction.
  2. Click on the Administration ribbon.
  3. Click Vault.
  4. Click the Vault you are working with and click Edit Vault.
  5. Select the Bridge tab.
  6. Select Login Info button and make note of the User Name

Set the Bridge user as an API user in Sage 100 Contractor:

  1. Have a user sign in to Sage 100 Contractor with Company Administrator rights.
  2. Open 7-2-1 Security Groups.
  3. Confirm the group API exists.
    Note: If the API group does not exist refer to the related resource below for how to configure security for API. This security group MUST be named exactly API.
  4. Close the 7-2-1 Security Groups window.
  5. Open 7-2-2 User List.
  6. Add the API group and at least one other existing security group to the empty Group column cells for the user identified in on the Sage Paperless Construction vault setup. Also, enter Yes in the Company Admin column
    Note: The username, in Sage 100 Contractor, must be exactly the same as the Login user name in the Sage Paperless Construction vault.
  7. From the File menu select Save
  8. Close the 7-2-2 User List window.

From the Sage 100 Contractor Database Administration applet, ensure the Sage Paperless Bridge login user is also an SQL Server Administrator:

  1. Connect to Database Administration for Sage 100 Contractor.
  2. Click Company Admins/SQL Logins.
  3. Click Modify SQL Server Administrators.
  4. Select the Sage Paperless Bridge login user name.
  5. Click the button Update sysadmins.
  6. Close and reopen Sage Paperless Construction and export your AP invoices.

DocLink: How do I configure security settings for the Sage 100 Contractor API?
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