AP invoices are missing on the JC Committed Cost with Detail report (inconsistent upper/lower case on commitment ID)
Description
  • The Committed cost with detail report is missing detail for several invoices
  •  JC Committed Cost Report with Invoice Detail is excluding some Accounts Payable invoices
  •  Only some of the invoices show on the Committed Cost with Detail report for a commitment
Cause

The commitment ID is alpha or alphanumeric and there are AP distributions where the upper/lower case for the commitment ID is inconsistent and does not match the case of the commitment ID in JC.

For example, the commitment ID in JC is ABCD-1000. There are invoices where the distributions have the commitment ID as abcd-1000, or Abcd-1000, or ABcd-1000, or any other combination besides ABCD-1000. Anything that does not match ABCD-1000 exactly in upper/lower case, is excluded from the report.

These can get created from Import Invoices if in the import file the commitment is entered in the incorrect case and the Capitals setting is not being utilized on JC Commitment in Custom Descriptions.

Or they were created from interfacing programs using the API (Application Programming Interface) to send/create invoices and the commitment was entered in the incorrect case in the interfacing software. Some examples of interfacing programs using the API are Paperless, ProCore, and TimberScan. (Note: It has been confirmed that TimberScan will follow the Capitals settings in Custom Descriptions.)

Resolution

Note: If you changed the description of Commitments in Custom Descriptions, the task, buttons, and fields will be named with your description. For example, if it was changed to Purchase Orders, the menu will show Tasks, Purchase Orders.

To verify the issue exists:

  1. In Job Cost from the Inquiry menu, select Entries, All Entries.
  2. Select the Current file.
  3. Add a column for Commitment (see Note above). Refer to article 20006 DocLink: How do I add or edit a column in an inquiry?
  4. Add a condition for the commitment ID:
    1. Click the Conditions button or the blue funnel button.
    2. From the Field list, select Commitment (see Note above).
    3. Under Operator, select Equal to.
    4. Under Value, enter the commitment ID. This is not case-sensitive.
    5. Click OK.
    6. Click OK.
  5. Review the results and make note if there are any commitment IDs where the upper/lower case is different.

To fix the issue:

  1. A Key Change on the Commitment ID will need to be performed by Sage Expert Services to change all commitment IDs to upper case. There will be a fee for their services. Contact [email protected] to request a quote.
  2. After the Key Change, the Capitals setting for JC Commitment in Custom Descriptions will need to be turned on. Do not turn on this setting until after the Key Change.
  3. Make sure in interfacing software that the commitment ID is always entered in upper case (all CAPS).

 

Steps to duplicate
Related Solutions

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