The delete button is greyed out when deleting an Accounts Receivable or Accounts Payable transaction
Description
Cause
  • Another transaction is associated with it.
  • The transaction is in a closed year. Only transactions that are in open fiscal years may be deleted.
  • Damaged transaction.
Resolution
Section 1: Delete related transactions
  1. Open the transaction you wish to delete.
  2. Click View Related Transactions.



  3. Double click on the transactions and delete them.
    Note:
    • If you are unable to delete the transaction then it may have more related transactions linked to it. Click on the related transaction link to see what they are
    • If the Transaction Type states Amount Paid at Sale then you will not be able to delete item from this screen at it is a part of the invoice itself, just continue to the next step
  4. Once you have deleted all associated transactions, you should be able to delete the desired transaction.
    Note: All associated transactions must be deleted before you can delete the desired transaction. If the associated transaction is in a closed year, you will not be able to delete it and therefore, you will not be able to delete the desired transaction.

Section 2: Correcting a damaged transaction

  1. Run the Vendor/Journal Sync test. Follow How do I run the Vendor / Journal Synchronization Test?.
  2. Run the the Invoice/Payment Sync Test.
  3. Verify that you can now edit or delete the invoice.


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