Error Unable to get AESCrypto.dll Library Address
Description
Cause

When doing installation for Sage 100 Standard 7.00.1.0 and PR 2.21.2, the following files are missing after the installation process in the Common Components folder: AESCrypto.dll and AES.exe.

Resolution
[BCB:1:Backup warning:ECB]


[BCB:3:Network warning:ECB]


[BCB:4:Operating system warning:ECB]


[BCB:5:Third-party support:ECB]


1. Rename 'C:\ProgramData\Sage\Common Components' folder.

2. Uninstall and reinstall Sage 100 Workstation Client ( DocLink: How to uninstall Workstation Setup for Sage 100 and DocLink: How to install Workstation Setup for Sage 100 )

3. Uninstall and reinstall Federal and State Reporting (DocLink: How to install, activate, update, and uninstall Federal and State Tax Reporting)

4. Go to 'C:\ProgramData\Sage\Common Components' and verify AESCrypto.dll and AES.exe exist. If the files are missing, copy from another workstation or call Sage Support 1-800-854-3415 to obtain copies of missing files. 

Note: Run Regcom.bat (Regcom64.bat) to Register AES.exe (Aescrypto.dll)

5. Try re-running Federal and State Tax reporting again


Sage 100 Advanced and Premium

Make sure the account running the Sage 100 Application Service has FULL permissions to C:\ProgramData\Sage\ folder and\or is a member of the Local Administrators group on the Application Server

[BCB:11:Chat 100 US:ECB]

Steps to duplicate
Related Solutions

Error 88 CI_EFilingCommon.pvc 280 when processing Federal and State Tax Reports.
How to uninstall Workstation Setup for Sage 100
How to install Workstation Setup for Sage 100
How to install, activate, update, and uninstall Federal and State Tax Reporting
How to run Sage 100 Advanced or Premium in Standard mode or "MAS90" mode