How to troubleshoot Sybase Service start up issues
Description
Cause

Make sure to run the Database Utility - Network Depreciation & Tracking or FASSVCMGR.exe as administrator.

This can be caused by:

  • An existing Sybase engine with the same name on the network
  • Incorrect parameters
  • Multiple dbsrv*.exe processes running on the server
  • Improper administrative rights can cause errors when attempting to start the service

The most common error when attempting to start the service is "Error: The Service Manager has encountered a problem with parameters. Please correct the parameters and start again".

Resolution

Continue through each step until the Sybase Service starts.

  1. Remove any prior versions of the server and client from the server:
    • In Windows go to Start, Settings, Control Panel, Programs and Features. Uninstall all old FAS or Sage Fixed Assets programs. Install Sage Fixed Assets - Depreciation Network again.
  2. Ensure the default parameters are correct in the Sage Fixed Asset Service Manager:
    On the server where the Sage Fixed Assets Network Server Components are installed:
    1. In Windows Explorer: Go to C:\FASSERV or SFAServ\common\FASSVCMGR.exe
    2. Right-click the FASSVCMGR.exe and select Run as administrator which will open the Sage Fixed Asset Service Manager dialog.
    3. The default parameters in the Service parameters should be:
      -gp 4096 -ti 0 -tl 120 -gd all -n SFA_Engine
      Note:
      If the Parameters box is blank, the Windows-Authenticated User installing the program didn't have full administrative rights to the server.
  3. Change the Engine name:
    1. Change the Engine name (the -n parameter) to something else (such as SFA_New or anything else without spaces or special characters).
    2. Click Save, then Start
    3. If the Service starts, there's another Sybase engine with the same name running on the /Network. Stop the service on the old server with the Sage Fixed Assets Server components installed, or set up the client to go to the new engine name.
      Note: If there isn't an old server, check client machines for Sage Fixed Assets Network Server.
  4. If the Service fails to start, it's possible that another Sybase engine is running on the Server.
    Check the Task Manages, Processes tab for dbsrv*.exe:
    1. In Windows right-click the Task bar, Select Task Manager, Click the Processes or Details tab, click Name to sort by name.
    2. If there's a dbsrv*.exe listed: Go to Start, Settings, Control Panel, Administrative Tools, Services. Click Stop on the other Sybase engine. On the Sage Fixed Asset Service Manager click Start, then start the other Sybase engine.
    3. If a lower Sybase engine is present, to prevent issues on reboot of the server, it will be necessary to set up a dependence:
      • Go to: Start, Settings, Control Panel, Administrative Tools, Services, right-click service listing, choose Properties, click Dependencies tab, choose the Sage Fixed Asset service to ensure the Sybase 17 engine starts first on reboot

 

[BCB:165:Chat Fixed Assets US:ECB]

 

Steps to duplicate
Related Solutions

Unable to open the Database Utility - Network